summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-mailwatch-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 06:01:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 06:01:43 +0100
commit0cdd46ad5d0cd7ede78815175764fdf76649d46e (patch)
tree8ece938369c65a410a308f3f05ebb9d2a7fdc008 /xfce-extra/xfce4-mailwatch-plugin
parentd33b3cf6cff9fdbfc8362bf854c3c34b2c28d518 (diff)
gentoo auto-resync : 21:04:2023 - 06:01:43
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/Manifest b/xfce-extra/xfce4-mailwatch-plugin/Manifest
index 0f45b2fb665e..f20db4908ac9 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/Manifest
+++ b/xfce-extra/xfce4-mailwatch-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-mailwatch-plugin-1.3.0.tar.bz2 551687 BLAKE2B 3ec841c32df059a2be99ad21c706be794d97c493e9ae1c1be5ec9006c45df51a766c8c89ef9f2941f6c411c18bfd5d01e8a510acfc4233cb349e1528346d0617 SHA512 07d4e4cc2f7d299a142d9e9b307c2797892a5febd8451d5291cb9574be0bd5daba677ee893fea3af49b6a8acbfb827ae0125ba11014df37b6c68a2734ecde11b
+DIST xfce4-mailwatch-plugin-1.3.1.tar.bz2 550836 BLAKE2B c4b53adec738308c37617b3512da8b3dbb6671b934c3ecdca904437b27374af935e92b2eb0d60b91ca42d8c2cb7d336ab687c7fa1d3106872ad368c2d13a3b7d SHA512 cc84c0511fff983283f6af132ff224f62373a1bb608f14b332a75f259f7842491b09f7d9f9d833cb31f81eb392a1b55fe4bf6da8a15b4c62abd2e9640392fb1d
EBUILD xfce4-mailwatch-plugin-1.3.0.ebuild 983 BLAKE2B 8fd87bcbc6a2f0b56a5823d00b4e765b13326bbfd00d24749379d3b88ad588fed35efccdb91fa5e0b576b104c4ea9927f4fa345eb9911a75a6aa3165cf149845 SHA512 bb2e5bf1a999110aae369f9194cc7d43b3222d7b424a40dcbdd1c586be1dac5dadbc68f0063ef77dc0b953742dbdd5f18faf4d3bdcbd2a4526ab4f7262da3a52
+EBUILD xfce4-mailwatch-plugin-1.3.1.ebuild 1127 BLAKE2B afc980768fbddf72601cef485def1e57d0b47e047781628adca6f8a8b47833416f46e4b0c0759e596979eb26a2aa8c0a724d1ab09316a4196d13a75d970e347f SHA512 b3974d41d8a1473ae4dd66bf9ff10066fe0fea10a25ac0059a589323706dcc7b787cc890b1ebed22051dee99babacf91f342688329e2475efb322d66da24ca00
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild
new file mode 100644
index 000000000000..bbd30e8fffc7
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-mailwatch-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-mailwatch-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-libs/glib-2.42.0:=
+ >=x11-libs/gtk+-3.22.0:3=
+ >=xfce-base/exo-0.11.0:=
+ >=xfce-base/libxfce4ui-4.14.0:=
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ ssl? ( >=net-libs/gnutls-2:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable ssl)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}