summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-indicator-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
commitda6a52f691ef980bab92d003d5df8f463c623af8 (patch)
tree4d89e0d5915f8a3f57c8f9c17420ba3f7b44b7b2 /xfce-extra/xfce4-indicator-plugin
parent80208fb578cf92cc308906660ca6d7860c6b2a1f (diff)
gentoo resync : 10.03.2018
Diffstat (limited to 'xfce-extra/xfce4-indicator-plugin')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/Manifest b/xfce-extra/xfce4-indicator-plugin/Manifest
index 4902492f6402..ef09ceddf2cb 100644
--- a/xfce-extra/xfce4-indicator-plugin/Manifest
+++ b/xfce-extra/xfce4-indicator-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-indicator-plugin-2.3.3.tar.bz2 380735 BLAKE2B d218c88e9b7cf862c2638f8ad6f9ec1a11797c3689d938e6a16ccea79622fb60f4b1273cf721bd72e8e26c99b1258743ecda52bbf3b52ed7c31ae052a49c2aed SHA512 d220ee625d10c857f2d65c52e8d561d8ff8448e8707161baf3ef8a1365fb5306d29c480f56edf5ead091fb3078ab0ebcb25088c676ad280e5c93208e36b95c20
+DIST xfce4-indicator-plugin-2.3.4.tar.bz2 406991 BLAKE2B 3d499f9f923e9cc51b25e2bed3dc6dfb6d4413c90d0a1afeacd14e0d1f33c9f9d5bdd6bdeb03a3e61bef0c3ec8cb1d1c766d89d921aaf9610bc797dc99a12219 SHA512 b1fd065c8221ae91d95b540411317cd67bb9b26d46c7cfe85ec90d7ccdcd11e7b8832008c8b6fb5c257e0b1a08360f00ad9da5520108024cc36c63d865ffdca6
EBUILD xfce4-indicator-plugin-2.3.3-r2.ebuild 1122 BLAKE2B 4472129c310f91804565775126762608fc0f9bbf95930062fed4e219e5f7707af15d09bd69cfc51d11ad03241ca65db53cacc324603bbe53a4e4a0ad145d3c6e SHA512 f1de69c1cd95e65f353140494a2775cd680ea13400c62d50a34f894f996b53dfe070c5db53475b9e43df483465aa5928c87ee70cb5a8848db2b39906fe019482
+EBUILD xfce4-indicator-plugin-2.3.4.ebuild 1102 BLAKE2B c8b0ad42c2a7a89b195452a11f79fb516819c83a7766cc5009ff18d8beed06be559265c6a907c7a997c91d425abc78059fb79fce5af2f11469c4c5d9ca62d882 SHA512 319be4056caccab0ac515518a79064fb2255b98d1eb448e4f2b36bbf6239a6b0c6b62de49b3d8d67a012aa764f3dba63ca451ca236173beb341758dff01699ae
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild
new file mode 100644
index 000000000000..4e41cded2668
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+ >=x11-libs/gtk+-3.18:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfce4-panel-4.11:=
+ >=xfce-base/xfconf-4.13:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ # libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ --disable-ido
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}