summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-indicator-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /xfce-extra/xfce4-indicator-plugin
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'xfce-extra/xfce4-indicator-plugin')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/Manifest b/xfce-extra/xfce4-indicator-plugin/Manifest
index 5d0cf17f582e..4c10ff9c0535 100644
--- a/xfce-extra/xfce4-indicator-plugin/Manifest
+++ b/xfce-extra/xfce4-indicator-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-indicator-plugin-2.3.4.tar.bz2 406991 BLAKE2B 3d499f9f923e9cc51b25e2bed3dc6dfb6d4413c90d0a1afeacd14e0d1f33c9f9d5bdd6bdeb03a3e61bef0c3ec8cb1d1c766d89d921aaf9610bc797dc99a12219 SHA512 b1fd065c8221ae91d95b540411317cd67bb9b26d46c7cfe85ec90d7ccdcd11e7b8832008c8b6fb5c257e0b1a08360f00ad9da5520108024cc36c63d865ffdca6
+DIST xfce4-indicator-plugin-2.4.0.tar.bz2 389228 BLAKE2B 6f627663d0a432ee74e871b55656c119f99c315d2f5095fd24a9eefc9338d280d5c371153377d575bc926707f30dc0602c7033bf09acdba1e247356b341393d5 SHA512 5b6e82d85357cec689f23a6cf69d379db9425956a531d8295a23adf52b1e00e3cd8acd822b13ab05d80321ff739c96aadc6e7526ec275421c341446e58a5fbab
EBUILD xfce4-indicator-plugin-2.3.4.ebuild 1117 BLAKE2B 279106516082dbdb43caa6baeb12ecba0f9170845804dbaca04df10b2d847929aed8357355db87101b48e1700ce1a49a04a36e1fd5488515e3d2ca3c11690687 SHA512 fb74791fdf0900d13bfa170717d1f7a5d07d02600f9fb7b1b5d5d319c493effcfbd5ef85d69d0f316ec3f1e36f4cd0b0b8e36b21caa73ffce1e52d7884e7669f
+EBUILD xfce4-indicator-plugin-2.4.0.ebuild 1108 BLAKE2B 170d06e8f007b49efb363f2acd6efd603d64606fa03c599d0a68416ba5e5bc6318310f4ce83fed0057f255cb8bf0f22176afca07fb3b91dcfc73473998f9f911 SHA512 6e15bfa86799baee2e34ea45088b06b668ac878081fb3b5392796e7742125b737e116849628985646cb76f2afd24dd4a02880609cd25211315c3c9893553fe5a
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild
new file mode 100644
index 000000000000..b93f7bda74df
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+ >=x11-libs/gtk+-3.18:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfce4-panel-4.11:=
+ >=xfce-base/xfconf-4.13:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ # libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ --disable-ido
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}