summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpugraph-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /xfce-extra/xfce4-cpugraph-plugin
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.90.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 6edb2f16f6fd..4f77d826de06 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-cpugraph-plugin-1.0.5.tar.bz2 328972 BLAKE2B 7c39aa6fd9d0d6ecc5bedce1d99d330765c329d1fa673b61282fdea654ebd997caa118f57dd0776008584eaa2dbe0a6ae7df532ed3b941b03b111f5ae753d2e8 SHA512 3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a
+DIST xfce4-cpugraph-plugin-1.0.90.tar.bz2 386127 BLAKE2B ec1809f64fa2fc142aa6efec315e2c138b7b49261ecce4735cc0dce225c24c69013f4b2a4250dcdf1513029765d81cb757e0bb38ebb3bd024b5b07fe2e0475d0 SHA512 7f2be5b41948ba4c730e6fd58038e96044ef8d007ae55f107a434308bfffc99071706c92854e41a589a807913fb98b9b216c141fc1d37c744275d5a3944aee09
EBUILD xfce4-cpugraph-plugin-1.0.5-r1.ebuild 816 BLAKE2B 02a7d506a7368ec6c39700f3b87def28e20a1a55812329b27444d650f6bdd0540dad2941cde8d31353e9382b69e9d8290ac0df471770eaa30adfc6a63fb133df SHA512 72e3664cff3909d98e6fa856a400e29230f738544b1506098e685970c1c3403c6ac81fde2ce97014346726b419df0707c0a6e322adf0a0aea58721aa2392b62b
+EBUILD xfce4-cpugraph-plugin-1.0.90.ebuild 817 BLAKE2B f09a905b38acf5b5b3c1fb1512c8ceaa6f759041a8a16e9d3bdd9fee8cfeb575e3a5d30e4f9fe8a7d8f60b78f4c7db1a46dc78a8cc03cec64cf29f4be957f49e SHA512 d65b56072dc31a0290c07a7152f9e587fda77cf9de0fec5ea456ce4aaa51bb20147625c55c3cc1cd18b1667951ec51824b39402f262e9fa7f4c876f480ca8ab1
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.90.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.90.ebuild
new file mode 100644
index 000000000000..684e97eec64f
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.90.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}