summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpufreq-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /xfce-extra/xfce4-cpufreq-plugin
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'xfce-extra/xfce4-cpufreq-plugin')
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/Manifest b/xfce-extra/xfce4-cpufreq-plugin/Manifest
index 891821bc73ad..b0208b311fe4 100644
--- a/xfce-extra/xfce4-cpufreq-plugin/Manifest
+++ b/xfce-extra/xfce4-cpufreq-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-cpufreq-plugin-1.2.2.tar.bz2 408480 BLAKE2B da6f38a57126b8ad06dd77c9a1f09ffee78e58b390b53b5020af8da403b51f20ed8965b9d0bd0da2add993228d19ec9fcaa15ea4c22b42011140a8bfdb440dfa SHA512 b0cab40fa0e6cdbb59606d7712b1b1479e4a1e8ca1aa5a59d43fc863ac10eee6477461c827805d7544db49fa6e821f0351973fe650e2ef1520ddcadcbbde096e
+DIST xfce4-cpufreq-plugin-1.2.3.tar.bz2 415151 BLAKE2B 5c3c1298c5dc0562f4daf8df9c4f9e0d26b638f85efc5ec35d8edc08bb54a8de46b5af98c603fad6042eca0353419ae4f55cb642dcac7e3ef47509fbb712d58f SHA512 e8e9d705f304681253b6e8fb7ff8724dc7c339fda750c2fb7f05dc4f295b483679c0e2884e508c108ca9018499b50f4ff48a7d4dae5ef7c8ab78f0018f1ef959
EBUILD xfce4-cpufreq-plugin-1.2.2.ebuild 808 BLAKE2B 80c8eb54af5cab054ddf19f65ce267f9379ca27dedf2824e56c426562e57604f83116f73f6dcf3c496e9aba906e82d80cfbadbc96f0a4eb1608e61bf81273055 SHA512 38b38bfac8e184db72f84730990afe7ee572210ea90c90289a880b49ebecdd380627150260a4be54556c1221fe340e55a2ea2030c48d0a0e6f200aadb569470e
+EBUILD xfce4-cpufreq-plugin-1.2.3.ebuild 815 BLAKE2B 8a801efb5c5cc46f22c9efafba35eae02b84f48129fe95553faafd8acf82b8f693b57e0aa5833aa1655cb62c76656cbc461a0805cd6c93fa720d126573362efc SHA512 218bf651bb50bc9fabc8bbdb688b7e316a1946a926d447661ff521ddc470c62233af933401909f5cae0b3d62d0ce4ded841c4307638207c247538bb652ffa0d3
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild
new file mode 100644
index 000000000000..3bf59fb4081e
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}