summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild')
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild
new file mode 100644
index 000000000000..0c6ed8e23b60
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}