summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-clipman-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /xfce-extra/xfce4-clipman-plugin
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index ae5d5ab1b9ae..5d74263b8362 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-clipman-plugin-1.4.2.tar.bz2 485244 BLAKE2B 6e183b82db5c3325691d04afa110c4dd83b013a94ed9b3b1b1b7bbb4166bcb1176a6b4ed52fd0b3256b7f73816a0031ea6084f31344a9ac3187b7b5fd25f01ed SHA512 f12d9e3e37a26f9dade5b76e73ac3998030112b53e7ec7b756128f7f1ee28d19a1d7b8d4a26e0ccb69aaba2f0ab2f6c4cd5a435bd1cc7efd81c05b711480eba6
+DIST xfce4-clipman-plugin-1.4.3.tar.bz2 492784 BLAKE2B f52dc92976e0b826b7aab2b8a3b9e099bb31e3d670911608d7a39c9805b011bb4c77db1fb01379e3244682a4bcefba617e246cc9ade50ecd275ea554d928385f SHA512 28bc8e2be8dd3eac13a7988b68933ce84dd8cc756f0a19636cd5850d6e36714a73ad9650a28ebfc54d9ad3adb23c242abf89806124b4e00fe7d1701be1b52414
EBUILD xfce4-clipman-plugin-1.4.2-r1.ebuild 1096 BLAKE2B 9c235901046b6824af441a84adea285167f9255e600931cb95b131fb5a2795efd235eba36222690ffb6de33fca02c502579db3b68b659c7a880f0a50b80834aa SHA512 616e00b26b6d64752978565c86478cea84dbe5eccc79397c18ba34a2392bae578eaffec02d957d9f953ff8a82a0583ad07480d7224e2a01570cd946b00e00c3e
+EBUILD xfce4-clipman-plugin-1.4.3.ebuild 1102 BLAKE2B 5e08e0aa70c80df83bb94b8cbe8f8dc7bae51f0a4d4deeb9687d6f9e425263afadc854874289902db9536b4ab9318f6910acea4203d4ca15a61d7fdf42d63c90 SHA512 d616da202b46956a6fa4ad92c6d32382eaa4f6fe07b6f051011a93f13d3d3de4a3c73bae9aaee40b5e75752866cca5932f415550ba83516f23b29e615944cd7d
MISC metadata.xml 344 BLAKE2B 2e5b2202a94c14c0b873c18bdbb7f02250049dbf45f23b82d44b2cb9fce79e7519a3fbc5f324b3c34f700ecf2314d051551283a5941ce16ff113b28f28852c3f SHA512 13ca7f9858f2eae8eaa1a4a43e371ab5b29433e1ac99ebe33d9678b7c3133d8e1639e146a93b6b4b1039278814d413d29e575a1a2784bbce0fcb50525e106065
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.3.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.3.ebuild
new file mode 100644
index 000000000000..496bd2d27d57
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.14:3=
+ x11-libs/libXtst:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.10:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}