summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-clipman-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 16:45:16 +0100
commitd12ee3457fd1a8bf18ede06882314fc1df30bd4b (patch)
tree33d42f682bfdfdf5fc26dd6bdd779853b8441ca0 /xfce-extra/xfce4-clipman-plugin
parent53aea9d709c9286028405b25584181507f47442f (diff)
gentoo auto-resync : 31:07:2023 - 16:45:16
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.4.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 02ea6118f622..cb219fa3f5f1 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-clipman-plugin-1.6.3.tar.bz2 486276 BLAKE2B f92c93e4ab57fbe37560c389620696f5c11fa8cbd328f29d4895c25c6f18fec88267cc152a1cab39084f08f8fdc070669b665cbad4089ae9577be776a3ad3663 SHA512 a117f64035a6656c2f8603d9b0adec18bcbe8e1ee6a80b838e4cc40480cc3510afe5f32815ff89b1936cbdbadadf8e1e645f0202d97cc877aec125b51b72064b
+DIST xfce4-clipman-plugin-1.6.4.tar.bz2 480785 BLAKE2B adc04a41e373fa62f822f0f11a2eac5b684ba89f718806c3d64bb8ddb88eb7de1cc059e3b0dd5baf8201ac8e5c3879d3e4fe57a11ba07684d5fb590062889a15 SHA512 e2cb4068ad00e89d848c72ab4c1b7aac0d41bdd006b60afd09e0323fca1c903eeee3b04a68221f5a2cb6be1347eac8879dfa6bd8b0483c2a075eb36e8cf65ea7
EBUILD xfce4-clipman-plugin-1.6.3.ebuild 1163 BLAKE2B 04624df426358311c512a0bc83eb1859e9184ab78b9061acdc31c89d1a655a0436e228756d67c4b240ffae58f50f95b53800709fd0a3f8065dde58769afa4f97 SHA512 17b29e3d4ea7964fe6dade6923f67f2617f2f80c99b87587b42ee06e4d1f27f97923e264ccd5a2302a2033706de0332d1da0a727c38a202fbf86d002bfa92571
+EBUILD xfce4-clipman-plugin-1.6.4.ebuild 1168 BLAKE2B 23dac444365e069c5a124f7f83911b307dc1516ddf5c468bdc8643f5146fc3d4f91250631490fa09d82fb0c5e88fdc3bff0dd813829412d016d241bf9af4e400 SHA512 686d3783068fdd8ca84217bea61c10b9e0bdb43e1069000e386a60c97ae1bdfe63ae9e9e5754f186d89d52eac07bd40a5a32331c9e3655336b495acc68df94ec
MISC metadata.xml 345 BLAKE2B 2a84642f72b32862062e911bc3d9495d77cde305206e3ba0d0bc82c792450506696d02e45b59d5035278bf53061016c72de278586e7669d53899c4d3c86585fe SHA512 0dbb04321b8dedc5bdfd3e7714cdbb3021ec1c866fcc61613081282c32316af6598e1516b629c6c6560a509abb0e6f378c0089dca1425b6c82ab796d5875a693
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.4.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.4.ebuild
new file mode 100644
index 000000000000..955d7912e0b2
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+DEPEND="
+ >=dev-libs/glib-2.60:2=
+ >=x11-libs/gtk+-3.22.29:3=
+ x11-libs/libXtst:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}