summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-clipman-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-21 06:39:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-21 06:39:12 +0000
commit0464b87d8be9fcf33aebbd906bc0d3a65c953cff (patch)
tree839aded9715eb71cd86edef0ea2a003400b6a63e /xfce-extra/xfce4-clipman-plugin
parentd39430b96ad12b39a0ce35745f3d45d980d1b328 (diff)
gentoo auto-resync : 21:03:2023 - 06:39:12
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 6c2c711735b8..69f787634ba9 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-clipman-plugin-1.6.2.tar.bz2 465656 BLAKE2B bde94cda7ec97d0af9f238bb3cffb69a7f469a03d27608681042ad701175a1900abed1d79bdc38d45afe5ed48da2054a837358bd150f5075bc194a9547bbf56f SHA512 4bd49b3b6311d232d422d92007638b05409bc0c90fdc20a394590000ac8c706c0502b99a3c89a0276ca1c0e2cfb0a151c78a0a8b18a16bbf65cc5778bcb51db2
+DIST xfce4-clipman-plugin-1.6.3.tar.bz2 486276 BLAKE2B f92c93e4ab57fbe37560c389620696f5c11fa8cbd328f29d4895c25c6f18fec88267cc152a1cab39084f08f8fdc070669b665cbad4089ae9577be776a3ad3663 SHA512 a117f64035a6656c2f8603d9b0adec18bcbe8e1ee6a80b838e4cc40480cc3510afe5f32815ff89b1936cbdbadadf8e1e645f0202d97cc877aec125b51b72064b
EBUILD xfce4-clipman-plugin-1.6.2.ebuild 1096 BLAKE2B 0b22fab995717be32864ec6fc0da79d8fcdb40875b4c30020015d5500f7e5ae932d8653653fb0e4c4430455414aa24f2a7ab5d88d5956773654d721ef57b53c8 SHA512 c4537368a5f90915da007dae3ad8e1c8fbbfecc2050e959bbb56c52610b8aa1358a34f62b9af214b3bafa577fe20cc7f43f1f4537b70bace683b382ce438d9ab
+EBUILD xfce4-clipman-plugin-1.6.3.ebuild 1168 BLAKE2B 23dac444365e069c5a124f7f83911b307dc1516ddf5c468bdc8643f5146fc3d4f91250631490fa09d82fb0c5e88fdc3bff0dd813829412d016d241bf9af4e400 SHA512 686d3783068fdd8ca84217bea61c10b9e0bdb43e1069000e386a60c97ae1bdfe63ae9e9e5754f186d89d52eac07bd40a5a32331c9e3655336b495acc68df94ec
MISC metadata.xml 345 BLAKE2B 2a84642f72b32862062e911bc3d9495d77cde305206e3ba0d0bc82c792450506696d02e45b59d5035278bf53061016c72de278586e7669d53899c4d3c86585fe SHA512 0dbb04321b8dedc5bdfd3e7714cdbb3021ec1c866fcc61613081282c32316af6598e1516b629c6c6560a509abb0e6f378c0089dca1425b6c82ab796d5875a693
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild
new file mode 100644
index 000000000000..955d7912e0b2
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+DEPEND="
+ >=dev-libs/glib-2.60:2=
+ >=x11-libs/gtk+-3.22.29:3=
+ x11-libs/libXtst:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}