summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cellmodem-plugin/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-cellmodem-plugin/files
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-cellmodem-plugin/files')
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-asneeded.patch13
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch62
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-link_for_xfce_warn.patch33
3 files changed, 108 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-asneeded.patch b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-asneeded.patch
new file mode 100644
index 000000000000..d0f9c6a4486f
--- /dev/null
+++ b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-asneeded.patch
@@ -0,0 +1,13 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=6613
+
+--- panel-plugin/Makefile.am
++++ panel-plugin/Makefile.am
+@@ -5,7 +5,7 @@
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+ @LIBXFCE4PANEL_CFLAGS@
+
+-xfce4_cellmodem_plugin_LDFLAGS = \
++xfce4_cellmodem_plugin_LDADD = \
+ @LIBXFCE4PANEL_LIBS@
+
+ xfce4_cellmodem_plugin_SOURCES = \
diff --git a/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch
new file mode 100644
index 000000000000..23f8eca7f2e2
--- /dev/null
+++ b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch
@@ -0,0 +1,62 @@
+Two issues in one patch:
+
+We use shared libpci so we don't need to check for libraries it might be linking to, such as zlib.
+Change mkdir_p with MKDIR_P for compability with recent autotools.
+
+--- configure.ac
++++ configure.ac
+@@ -14,6 +14,7 @@
+ AC_PROG_INTLTOOL
+ AC_GNU_SOURCE
+ AC_HEADER_STDC
++AC_PROG_MKDIR_P
+
+ AC_CHECK_FUNCS([vasprintf])
+
+@@ -33,14 +34,6 @@
+ echo "> Not using debug"
+ fi
+
+-# PCI library needs libz.
+-
+-AC_CHECK_HEADER([zlib.h],
+-AC_CHECK_LIB(z,inflate,
+-LIBS="$LIBS -lz"
+-)
+-)
+-
+ AC_CHECK_HEADER([pci/pci.h],
+ AC_CHECK_LIB(pci,pci_alloc,
+ AC_DEFINE(HAVE_PCIUTILS,[1],[Use pci utils to discover devices])
+--- po/Makefile.in.in
++++ po/Makefile.in.in
+@@ -37,9 +37,9 @@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+ subdir = po
+ install_sh = @install_sh@
+-# Automake >= 1.8 provides @mkdir_p@.
++# Automake >= 1.8 provides @MKDIR_P@.
+ # Until it can be supposed, use the safe fallback:
+-mkdir_p = $(install_sh) -d
++MKDIR_P = $(install_sh) -d
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+@@ -98,7 +98,7 @@
+ install-data: install-data-@USE_NLS@
+ install-data-no: all
+ install-data-yes: all
+- $(mkdir_p) $(DESTDIR)$(itlocaledir)
++ $(MKDIR_P) $(DESTDIR)$(itlocaledir)
+ if test -n "$(PO_LINGUAS)"; then \
+ linguas="$(PO_LINGUAS)"; \
+ else \
+@@ -106,7 +106,7 @@
+ fi; \
+ for lang in $$linguas; do \
+ dir=$(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES; \
+- $(mkdir_p) $$dir; \
++ $(MKDIR_P) $$dir; \
+ if test -r $$lang.gmo; then \
+ $(INSTALL_DATA) $$lang.gmo $$dir/$(GETTEXT_PACKAGE).mo; \
+ echo "installing $$lang.gmo as $$dir/$(GETTEXT_PACKAGE).mo"; \
diff --git a/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-link_for_xfce_warn.patch b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-link_for_xfce_warn.patch
new file mode 100644
index 000000000000..5ffb48b38f95
--- /dev/null
+++ b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-link_for_xfce_warn.patch
@@ -0,0 +1,33 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=6613
+
+xfce4_cellmodem_plugin-pin_helper.o: In function `pin_helper_pin_entry_callback':
+pin_helper.c:(.text+0xa6): undefined reference to `xfce_warn'
+
+--- configure.ac
++++ configure.ac
+@@ -18,6 +18,8 @@
+ AC_CHECK_FUNCS([vasprintf])
+
+ XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.20])
++XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.20])
++
+ XDT_I18N([cs pt])
+
+ AC_ARG_ENABLE([debug],
+--- panel-plugin/Makefile.am
++++ panel-plugin/Makefile.am
+@@ -3,10 +3,12 @@
+
+ xfce4_cellmodem_plugin_CFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+- @LIBXFCE4PANEL_CFLAGS@
++ @LIBXFCE4PANEL_CFLAGS@ \
++ @LIBXFCEGUI4_CFLAGS@
+
+ xfce4_cellmodem_plugin_LDADD = \
+- @LIBXFCE4PANEL_LIBS@
++ @LIBXFCE4PANEL_LIBS@ \
++ @LIBXFCEGUI4_LIBS@
+
+ xfce4_cellmodem_plugin_SOURCES = \
+ cellmodem.c modem_driver.c \