summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-battery-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-20 05:59:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-20 05:59:19 +0100
commitdcf9ac80d0667a18496506842a8903ba5dab2fc7 (patch)
tree2b00642cd6bdbd7de71159350f01b424ffc37420 /xfce-extra/xfce4-battery-plugin
parentf7e94be7540157809ed892278b6765c368a5a912 (diff)
gentoo auto-resync : 20:04:2023 - 05:59:19
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index fb3863b6b394..40845d068cf5 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-battery-plugin-1.1.4.tar.bz2 458485 BLAKE2B 5af18d0f8944afdc6c93852220cd87020d7ea18ce27e224def5ed71f3d9490e2e30982bbff322a76feb3d6464888a8cd64e40c9938484256432537ea1a150009 SHA512 6a59630800a79d2c62434c1c50f5d891ae9ebae48037ea0859d6edd66c856a76e6f11c6e8866ca3c94ae1e5b57bdba4e9fadd4bc92c7fcef278cd2f7b82203f2
+DIST xfce4-battery-plugin-1.1.5.tar.bz2 465191 BLAKE2B 6aa8f1d3cd3dbf3fe29fede154ad51c7cf521c04191699582678e930c2ff0a20c2f50bda22d9576b1f29b595767c5ee1ce4a7ef60cdf3fd69271796d2af8ae2e SHA512 e6e09a4839911dda50fe1fed100d5fd46f6da47e5042529c2cbffa5498babc838bed56178baa23d2162b70cd6e5f005276d4b9f1fc44a1891737c94c2bf525d0
EBUILD xfce4-battery-plugin-1.1.4.ebuild 947 BLAKE2B 9597ec94647ad333f7fa3ac115be76fe23774371985c604bce0d0c1557e1f2943d33447c25644ef0e7b645ddac8c836839a77dc115ce1f9ac77cc9fa6eecf85c SHA512 4ad657d1ed698f4d85270990fa48649257d4cbc395ff9ac80e750bb51dbc3ba6e2fba0f15ac78192e777373126060ade7dbcec58b0109ebda328ce34786beac8
+EBUILD xfce4-battery-plugin-1.1.5.ebuild 1024 BLAKE2B 65c5bcf9f3f8e60528eca06b4f704e732d159f994782b3adaff97bc8ce3b0346a8a946e66d5f1703ad4ecabd635c8c2fbc48cbf725747efe535c1b926a85dea3 SHA512 c8198bfdc1734bf2a0b7e700ccafb90be1dd994f19160e8e5d0b1928c68be6b65d8b3647c034a56882e80b824dbb8f65cc28ff28b537cc89d0a663de0819cedc
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild
new file mode 100644
index 000000000000..36a3ac9eb607
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-battery-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-battery-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.16.0:3
+ >=xfce-base/libxfce4ui-4.14.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}