summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-battery-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /xfce-extra/xfce4-battery-plugin
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index 01ae7eb63249..4efa70fd6af6 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-battery-plugin-1.1.0.tar.bz2 398621 BLAKE2B 461f32e07708c29f2157c8909ba48a43458c06c9622ec0835f4cf6abb0b1232bc35f23a7e945315eb2d49048b9c0023da3a27803cf95217374962531db986e97 SHA512 d3f5b6d3657abfba2c4c5cb3ab8ddc87f4862f24eb614cb91af48332b3082c3dce7f32eb2e3cb8a9d501ddb01c6259c4fbfbab8ed9c221633e47eb17c623cf09
+DIST xfce4-battery-plugin-1.1.1.tar.bz2 465880 BLAKE2B 09f257226009de387b8965e8233aae9a0c756fa2c854f1bdf346e23638a0c55b7100c57eb33111c2f8e20908350baba2a608cf7e2a7046770d5dd4b758ce4e61 SHA512 15c0755f95cc03db95f8fe61faa87607dcdb24622c8de3a7941c254e15bf3d65b6683e5a0ff1fd96ca252afede6763f4440c8455665e346169b1107ad44d6651
EBUILD xfce4-battery-plugin-1.1.0.ebuild 1101 BLAKE2B bbc742ccf3cfb93277e3f5dd7eee324587f14a154bd286688ab1d715a6247e291b2a5f087086538351d5e217bd2eb0862b734331ae29390e024ca592af5120a5 SHA512 908ef23e02b60659d1478e042ff5239d10aa539db7bec59504932a054e216690a3be5a6909a50026e89b038ac01bc8107a828b56a04a8bef556670ab541d994c
+EBUILD xfce4-battery-plugin-1.1.1.ebuild 1064 BLAKE2B 3ad1f7ec6db0020b11738588a5300456aff985046548451ff9b12805b2b3b72e13e2579a033af9b8468924818fbdccc49cc977b06e3ca1b8bc6ba66434b0f0c9 SHA512 9c9a856858a50bc683497c501e406ddc722659aa7e8903d88fc859ced17bd25d0a6ed144b2aa273566ab00fdddc19ca3c2d927db6689fa72dfa441a881a83bb2
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.1.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.1.ebuild
new file mode 100644
index 000000000000..70ccc4350916
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24:2=
+ >=x11-libs/gtk+-3.16:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}