summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-battery-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-25 06:31:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-25 06:31:02 +0000
commite80134587e8d959a88dba7dd3784895372e205c8 (patch)
tree912d9772fcc93ec668b363146cf81e45519253d6 /xfce-extra/xfce4-battery-plugin
parent17e417b73cb3e25edbc6541bd107bc9c593d66bd (diff)
gentoo auto-resync : 25:12:2024 - 06:31:02next
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index 106778155788..3884195ec2ab 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-battery-plugin-1.1.5.tar.bz2 465191 BLAKE2B 6aa8f1d3cd3dbf3fe29fede154ad51c7cf521c04191699582678e930c2ff0a20c2f50bda22d9576b1f29b595767c5ee1ce4a7ef60cdf3fd69271796d2af8ae2e SHA512 e6e09a4839911dda50fe1fed100d5fd46f6da47e5042529c2cbffa5498babc838bed56178baa23d2162b70cd6e5f005276d4b9f1fc44a1891737c94c2bf525d0
+DIST xfce4-battery-plugin-1.1.6.tar.bz2 569701 BLAKE2B 5f401ff5f9bc447f4b73c5341ece8659c74cb2e68e0cd14eb982d3a831f20948250084a16c99c45afde8cc1a001959fdd5a36402400106281152f71a760a3059 SHA512 809c0f24adf914501ae9431af43caa36f72594dc686451bdd27b895cca80a51e76120a1cf191944e4b8b004d18ecc890caca9faa725cee230516bb1d0ad57415
EBUILD xfce4-battery-plugin-1.1.5.ebuild 1022 BLAKE2B 45305a3e92e86f3ed0c730f81488524c2a8c8777ad8420aca19177de3694e624f97ab00f242475437617d74914687754156bf17b4b8c102ebfa7fc129f207568 SHA512 309b6c44ddeb4d9fb90c30cc34513a43e675da1ff27febc03333356a97054564a0eb9ce277b3c545e06aa2013b70a17f897fcbd42f345a784f36dbfbad9066c2
+EBUILD xfce4-battery-plugin-1.1.6.ebuild 1033 BLAKE2B 882e3c51d550d11bf2aa1f132d776f08b8d7f7388473e41e863e9ccbb412e4d666a84868a6ce16e5a388e55afc13f709e932294f45332584afdd1aef7dcd109d SHA512 3f4ac813b27c42e342887f7c548c8d68fb40f17f195c6b964e1e0ffe018010f2740cc0c915a329d004881a78d908d6ac3ad2d09cb08867288bdfdbf24a08dfc7
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild
new file mode 100644
index 000000000000..1f3018ef0e77
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-battery-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-battery-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}