summaryrefslogtreecommitdiff
path: root/xfce-extra/thunar-vcs-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /xfce-extra/thunar-vcs-plugin
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'xfce-extra/thunar-vcs-plugin')
-rw-r--r--xfce-extra/thunar-vcs-plugin/Manifest2
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.90.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-extra/thunar-vcs-plugin/Manifest b/xfce-extra/thunar-vcs-plugin/Manifest
index f298e9a593cd..5ebb75a969f6 100644
--- a/xfce-extra/thunar-vcs-plugin/Manifest
+++ b/xfce-extra/thunar-vcs-plugin/Manifest
@@ -1,3 +1,5 @@
DIST thunar-vcs-plugin-0.1.5.tar.bz2 478866 BLAKE2B 9bf2b060d88a4379f02c0e8af1829f4cf621e2590f7885f59d9af56d825c1d9d218c56c3b97420087b46eece0eb6c15146f6630569928c8523fa34bcfdbbcc22 SHA512 0315613fe97d5cb2fa9589af49bdb5074f20c83b52d5f7d4a151091839679b4617e8e0b20df85914b7bcef2464173dc1bd2bc182312364c7d5a94171aba28983
+DIST thunar-vcs-plugin-0.1.90.tar.bz2 537001 BLAKE2B 0f2a77af75a33fe514892a1eb7f1df92be6e50d5c0aeae5f9350db648b10b868b3ff0421614ab7de681ff445d5a1f8ac9a5749e235c06cc3a039cd89b382fd7d SHA512 6231bb863d9b884cd27f26e6cabbc3f8d3b39dc162f867932923408636bb96621bb60aa1bfa9b4637f5eed694e623cd911e855dde00d382b2a1bf36bb6b44e63
EBUILD thunar-vcs-plugin-0.1.5-r1.ebuild 1037 BLAKE2B ca69c54c458516c9aa483d2a4b025be9263576cea5ce5196e4f5675b0c420275bcca3347c7b89e1933e8ada1d4c6d3226f49b63bbe45bebc289d6f9ea4eedf8b SHA512 da52ce247112351ee3799c56cc1d6832104a9b3c29445b7baf3dae7733ea11ec1efb9b9fdbd9d5f660764569822303027d0801bab473e1c4694ec0fbeae3e07c
+EBUILD thunar-vcs-plugin-0.1.90.ebuild 1003 BLAKE2B 8abc87619f0a8803428f694419fda7538d4f5c7977902dd13279637a47e8e44ffc13436d85701230e7cf7460026c2c7d0d8f5b0d876b98a24ab2a10539edde96 SHA512 e85c05d0670b8af44c0f3df1f102bfca13016257f3598103c0015b29e61bda56a6ce4aba6c4724f5f9c7791f122b406fd30ef9e89cb9bd1eeb87b3848969c5cf
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.90.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.90.ebuild
new file mode 100644
index 000000000000..ef9f9a686aa4
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.90.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+git +subversion"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/exo-0.11.4:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/thunar-1.7:=
+ git? ( dev-vcs/git )
+ subversion? (
+ >=dev-libs/apr-0.9.7:=
+ >=dev-vcs/subversion-1.5:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable subversion)
+ $(use_enable git)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}