summaryrefslogtreecommitdiff
path: root/xfce-extra/thunar-shares-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /xfce-extra/thunar-shares-plugin
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'xfce-extra/thunar-shares-plugin')
-rw-r--r--xfce-extra/thunar-shares-plugin/Manifest2
-rw-r--r--xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.3.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/thunar-shares-plugin/Manifest b/xfce-extra/thunar-shares-plugin/Manifest
index 613cadfcbf9e..effa91998848 100644
--- a/xfce-extra/thunar-shares-plugin/Manifest
+++ b/xfce-extra/thunar-shares-plugin/Manifest
@@ -1,3 +1,5 @@
DIST thunar-shares-plugin-0.3.1.tar.bz2 373071 BLAKE2B 25562e8583503a170d15b611aa07c2e1426bee292b8cda4ae9c4eaa6861fa4c1a2fec531b3bdeca6bf06097e4bb2be924fddc07d73633c5f9d714837e8fe80f5 SHA512 08fca3fbf88448808ca84753d867c71114d1700fa63d792771c3c99a6da8c69ee7c53f05f883b2180cb06d2c187ee2a4d1fc889c7f392b1ec0d5981532284a3c
+DIST thunar-shares-plugin-0.3.2.tar.bz2 365609 BLAKE2B 25f959d81b689dabe930910402dddb047208caf9400db9830b1e5a1f8fad6b676706ce79b9c7e0036292c995451998ff40cadd60ae2eaa47bcaf7994772081ba SHA512 26c3085b3ede065a0c9cdaf5a97d1617d581148e14d35e690f592316beb4e261f31cf864b5f47449030a77cdab33a22cfd4f9f36ccc47d4736e754de459b89e3
EBUILD thunar-shares-plugin-0.3.1.ebuild 629 BLAKE2B 5e80ad27ddcc9079ad9768a6ec21c99553d457a2f0868ac1429def73e3be68ccd539fcaa95c4f536d08505073c6d6d4d9b591d5dc653f003358ebef109328233 SHA512 8f71cf08ae73e3c6cb06b564b0653e8d208435dc87b94d7397bf81f315604fa1fc0a95cc4877620694985f3f481ff8ebe273b303722768456581fa1596c950e3
+EBUILD thunar-shares-plugin-0.3.2.ebuild 713 BLAKE2B 20eae93867547dbe6d5ae88d3c0db98f8572fde488f0f11b7e0c83e36d6353a19a66cf8c40086651564218b75379036aaed6c95d5261ffada176602bb1db6e54 SHA512 5c283fd5ed95aae4bce9e78346f8153d6d855b7039adee981d0da23bf24f00abab826d46e1da0495f280b75457f2702c01864399ea9571d1c7fc0a74b16e4e52
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.3.2.ebuild b/xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.3.2.ebuild
new file mode 100644
index 000000000000..265a76a338ca
--- /dev/null
+++ b/xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Thunar plugin to share files using Samba"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/thunar-plugins/thunar-shares-plugin
+ https://gitlab.xfce.org/thunar-plugins/thunar-shares-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/thunar-plugins/thunar-shares-plugin/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.26.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/thunar-1.7:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}