summaryrefslogtreecommitdiff
path: root/xfce-base/thunar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /xfce-base/thunar
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest2
-rw-r--r--xfce-base/thunar/thunar-4.18.5.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index d5d03d239fed..7ca77899b7d5 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,3 +1,5 @@
DIST thunar-4.18.4.tar.bz2 2836333 BLAKE2B 22ab64ae14bbd15e16d314f2252f02fc8a5ae3043502bfc6a1f43c3e28e735e42d1e040db4dc9c3c7d4df6426c16233da78f30284b1679d59b9ada2cf9051fe2 SHA512 c182abc9fbde79f802c2fac01375be8b29b5da36c665f1de1c005ec09561a865c502e9741a3336ef467d05b215041b452200b063bc33d572b0857f901728d9ae
+DIST thunar-4.18.5.tar.bz2 2831920 BLAKE2B 7923c110d4c2bd2ee1f9f0a99638750e41b3da02d3ca32b188f84859ba942c243cb050e14290c390b9766070f72ac4ef006dd2a8c6622740fa7802f1f8fb5c6a SHA512 bee561e63e6732022a9434dd6c297e89ecff901ffbdbb4b4063a74ab9e51dadc09b52123586a82b7e16d69cf4205fa7dcc2a29261e4e9c0b62daa03cf38380ca
EBUILD thunar-4.18.4.ebuild 2102 BLAKE2B 6b265e98b993a780bcd0419ca08c0cffcc77bcbc5c604a11d559d69aafb56e5f5e5540a04fdf3462127520ae1ae029edbe0ff342daf0ccba1de2e668d274c8c6 SHA512 98e689e81569705ba631225cba62c65ebd877a30909389f5e0b1efa34baf6c70190216f9e6e79a1e19534fa47fd7f4b109f77192135c57417c8d0f1344e7a6ad
+EBUILD thunar-4.18.5.ebuild 2108 BLAKE2B f5520d18862ff4c7ffc6b37237f955da368a4e37210dbea5621197354b6b10e9d621db9009c901716d094b3277f2fcb4f77b20f95d8e01ed637b5a1222fdf3e5 SHA512 aed4c181021d97d380d7ba0dc6d911487fcc76e22c737cf8db050543a7eef2f0a2e408c453011457b017723d0741de65cfdf30309772a2d6a06d61b79e81c3f5
MISC metadata.xml 373 BLAKE2B 8565ee8f50389c9ecd482437d0081ce6c9ed0ade1fffd724c2485c03c708565c91bf89a974a37a3deb541e2e0cf35a19881c8b3ee39182f26d1c522088466ff1 SHA512 b73f53699dc6b936d1baa9bffde644a86481083b4ca333b2d5148bcd03c43e9ff9577c6b35a2e40d89071158c4b4deea4d6317e40959f4344b7f974ac3d22c71
diff --git a/xfce-base/thunar/thunar-4.18.5.ebuild b/xfce-base/thunar/thunar-4.18.5.ebuild
new file mode 100644
index 000000000000..c3bb395fb212
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.18.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/start
+ https://gitlab.xfce.org/xfce/thunar/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gdk-pixbuf-2.40.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/exo-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.6:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre2-10.0:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? (
+ >=gnome-base/gvfs-1.18.3
+ )
+ udisks? (
+ >=gnome-base/gvfs-1.18.3[udisks,udev]
+ virtual/udev
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre pcre2)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}