summaryrefslogtreecommitdiff
path: root/xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild')
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild
new file mode 100644
index 000000000000..7e4dd9b0c366
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A compability library for unported Xfce 4.6 plugins (DEPRECATED)"
+HOMEPAGE="https://git.xfce.org/archive/libxfcegui4/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="startup-notification"
+
+RDEPEND="gnome-base/libglade
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.10
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}"/${P}-no-xfce_setenv.patch
+ default
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable startup-notification)
+ # glade:3 no longer supported on Gentoo, #575166
+ --disable-gladeui
+ --with-html-dir="${EPREFIX}"/deprecated
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/deprecated
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}