summaryrefslogtreecommitdiff
path: root/xfce-base/libxfce4util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /xfce-base/libxfce4util
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/Manifest2
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 5e227355436c..ade129b5d303 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,3 +1,5 @@
DIST libxfce4util-4.16.0.tar.bz2 508328 BLAKE2B 99578b898389bd90841a7f903f5473b2ff357cf81256efe1019425b48da32401ce238deffefd299987477f4cdfb77e86e415b55049863c30bf16e0e641e08c72 SHA512 dce6992c3da73367461d7464794a9b2a5503666113682e07a86e18b1c5383de2b087809448d5729097571f4fda6b4af5f4f4600848514ab2ab4b3f367ca26f5c
+DIST libxfce4util-4.17.0.tar.bz2 531849 BLAKE2B 5c5de18703ade8bfa6a6be823144839afc309422131c06679a54b405c8d6aced4f1ccd0b9d0158931b6eed90aa48ab29789d1173c98541f92d3813c197283762 SHA512 4cdca029fb5e8b1cb5b34ca54aa1003918626824ee162adf43cede4c717b5e9705a5c0ff73f1a6348db320c4f3dddf4c9b8c760fba55f00d42bdb8fe7a9d90fa
EBUILD libxfce4util-4.16.0.ebuild 1041 BLAKE2B fc3943cc33715dc765858991b9a42396c377e65d556d0d2fee0c630efd09bb50dbc962aa53007fc0290d0f129af7a71c8f911b4737f564904e80bbd4035ce62d SHA512 b464c87b4a85ec3b45b14e159f4f9f36c5ebe2a3bdefcb21c76a901d4435bda8da287605cc399d88b07062c81dc1982be47663c9e6b9ba9044755c079ab19005
+EBUILD libxfce4util-4.17.0.ebuild 1048 BLAKE2B c1722bf8d881cefcce56d3e32bccc3fbc21a12fa1f3405d92e3fbe06d6841e94c34454a2f8adf2f66a9cdc2f84df1609273243659969bc76fd6df00a683a085d SHA512 47d588765fff62cebf12b6d738057d307740b1cf9e6cb5edde30ff0dbebda75accb89125ab88d530a7bcee4b2425ca734cada1a1cb372de37f731d33512df285
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild b/xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild
new file mode 100644
index 000000000000..f17b8a526eb7
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.50
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}