summaryrefslogtreecommitdiff
path: root/xfce-base/libxfce4ui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
commitc55c2cf7b5e5e8ce7f21c53ee7996c2ea918279d (patch)
treee8bb447a647aa737a0da2ede957972eb72e7dcd4 /xfce-base/libxfce4ui
parentd41bd0acd3d0cd850cdd815b12e69ee2c89c5697 (diff)
gentoo auto-resync : 28:03:2023 - 21:51:31
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/Manifest2
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index dbb7526bb725..8ddd7e6daf6e 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,3 +1,5 @@
DIST libxfce4ui-4.18.2.tar.bz2 901949 BLAKE2B 17bf0541646735ec54da5f322d858896fa2fd132fe93864372a67d4936b4467def749f4a0dd4f3d23ecb7a2b3843367f88ccf74b7e040e7ad6f6c15fec45055f SHA512 758466e2e3096791b99e1a00c9f499d95327581ad336fc1ab0d51e3d150206d522f44c2e6053b0032499dd0cb337510cf6940dc77499cef3ecbb484de7787457
+DIST libxfce4ui-4.18.3.tar.bz2 905070 BLAKE2B 0ed4bdaa1135d22d5155e22d8ecaaca2b2be714a097f26fc0388ea4bfdf39d8bf854e85ee1ace590000000d81034e414a7a0782ba3218e09901a1e0afdaf5fbe SHA512 697d883352189426b36d6c06254404b1dd2ba5f9630691b7dfddb2496d7b0233e807485155ead02dfaa73dc543eee7d8e459dc72ec56f646ec020fc9142edd28
EBUILD libxfce4ui-4.18.2.ebuild 1733 BLAKE2B 77e3722a235e09c5e802fb57b648030baa054b269788c6f661492ecb27b08ef4e9893b491495ae5c7d14d559a32b8823f45827897a2e72f16ee21ac2286d3b5b SHA512 94534883d35f2dd5458cf58de698eb3b7596c8e032fdc60584a6bb7ec563cc2eb1607b1056876cdf19db4f99afacd52824a0f9451425da1a2a5f04ba1054394f
+EBUILD libxfce4ui-4.18.3.ebuild 1739 BLAKE2B 0da39cc9521bddbe924e82d216e2f2834daf2f0762b0c0c7e2ee6eaf0bf7f30c3a458f161f29a7a68d8b710dcbf02dcd45b7ba29e91c85ff34acccd78f658042 SHA512 c496066821e64e30df458642b5e316e569693b2589257c326f96ebef7077dca8d77e03ebd837a85406c06fab6c3b76ef7ec3fc0e1c8937cdf05d0af9f4e81c61
MISC metadata.xml 415 BLAKE2B 96ab20930d257e21f8cb46d95f24e7d0fe7568aba5cc097ffb9ec46a5341d58dcf366522de79d8c04b575cd0cf6b96724ed969b8d6338cb842bd50787620ea9b SHA512 9712241bf2f9bb14ac6969f02768e7c4a159f7349eff4a7c9bc8fb779955a555b4cb5770ed32203933e603acb2fa9456cd989a62e274c94320e81e820555644e
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild
new file mode 100644
index 000000000000..31a8ab010145
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}