summaryrefslogtreecommitdiff
path: root/xfce-base/garcon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
commitc55c2cf7b5e5e8ce7f21c53ee7996c2ea918279d (patch)
treee8bb447a647aa737a0da2ede957972eb72e7dcd4 /xfce-base/garcon
parentd41bd0acd3d0cd850cdd815b12e69ee2c89c5697 (diff)
gentoo auto-resync : 28:03:2023 - 21:51:31
Diffstat (limited to 'xfce-base/garcon')
-rw-r--r--xfce-base/garcon/Manifest2
-rw-r--r--xfce-base/garcon/garcon-4.18.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 6b65e26019b9..61bc18b69001 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1,3 +1,5 @@
DIST garcon-4.18.0.tar.bz2 550674 BLAKE2B 93bc218c4455c61109ee7086a8cb822aaa154aaebd082c10ae9fd551019bce0fe68a117552c05fbe3a97c671036b5306703ba3c320d9b886715a83fb038c95b0 SHA512 c4b49ba47ac33823199a68ef9bdcba3acfcedde62a96a8a8b3af2bb1f28b3a5fe3e960ee93bdb964fbc01b039047d77f58fbe5b1f9fbd2ccd3d3f968e416a55c
+DIST garcon-4.18.1.tar.bz2 554562 BLAKE2B 395cc8f7c7029196f25ecb52d393989ab0df0d9ddd34ec1fc4b0a2ee46b1a059a87c75797adb84d7557523e8e0c464278344fe3d793f05941a90874bdc8e036d SHA512 8e6d091beaf1aaa85cc16cd5e562191e0e6858a47444a23d95066f9afa3f8a70f7a61bc9fec33fe401945637e810441cbd6f961f41b40e2d2ce7a1ce4fce78a0
EBUILD garcon-4.18.0.ebuild 1228 BLAKE2B 02bfa8dbe013024d4db5347ba7b7fee2d152315da16998814b992cad860b42c3ba690c6a1f1447515c200cb9207afa7ae56f6650cf616edc774d232f255dba0a SHA512 853e1960b3dfe645d5df7b35ce709975f87996a20eb22a24712fcfcfefad4e2905395d6439498a04559cffc17993b973f2e00ceb9148258707b9b2a10cc5948c
+EBUILD garcon-4.18.1.ebuild 1234 BLAKE2B 8848741b6f2562c6ea24987802bcc3003413c83d5e534944c2edec503c0cd220d98b0a7b8fcb2293514c68f7f2bdf6ee2337f5072b01a702e78fd2b2fb5a11b5 SHA512 0b14f2f533fafe7bd79609c361b89f737de882541215267070fc8ac42a6598bab7c05c236a181ddc9276f6a7176a35a9dacab3e05ef9f255dae81f7c4e2ea323
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/xfce-base/garcon/garcon-4.18.1.ebuild b/xfce-base/garcon/garcon-4.18.1.ebuild
new file mode 100644
index 000000000000..1ab860690142
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.18.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/garcon/start
+ https://gitlab.xfce.org/xfce/garcon/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( >=dev-libs/gobject-introspection-1.66 )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}