summaryrefslogtreecommitdiff
path: root/xfce-base/exo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 22:00:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 22:00:32 +0100
commit4fe36de7142d972c061813e413f66ed4bcfc38d0 (patch)
treef95577c134cc26bf3d7223b38b8c76311d57fc12 /xfce-base/exo
parent2e4d96d87e04d8b2164f764dee727cd9057cf88d (diff)
gentoo auto-resync : 15:10:2023 - 22:00:32
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest2
-rw-r--r--xfce-base/exo/exo-4.19.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 2218178842a9..ff01e133a707 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,3 +1,5 @@
DIST exo-4.18.0.tar.bz2 896849 BLAKE2B 99cd22b9f2c806907449afdd640abd85be2ec37269d0436a20300ac88ee4fbe39807e39ba51ae8fe82d621c478d65d1f452209779e7d48caee899305b40f3a27 SHA512 32f3a319ff31a37cdaf8e2e7bdbdbaa9b797d6731a27854838b47d6078f45af83ed1a664aef4663f616fd9abcae9233c6f68ab2cc18599f1b2ced487602c51ce
+DIST exo-4.19.0.tar.bz2 1095228 BLAKE2B e0a368032d3cb148a9bda96e5eeb6a9364a568e809f1c0c31d13e82e1357c22e401a8ec486e19da8001fe7ff7570870fecd5564d2ccdc38947ddb51e5eec00df SHA512 656ec021c19618daafd80df6701e7076ad167520388cbc1727d22da9c6b4eaa4f7e12b53f6131f2d2e10986b0440cbf808aeb6914c1a91d2e7af711c015967fc
EBUILD exo-4.18.0.ebuild 977 BLAKE2B e3792b79f80ccaf62b85866560a6b8d188ef18f3013138bf3747f33e6833ef19cfa81a7a4f5bbff876f8427b215787c4a4a225f8ef834dfba2cfc848734b83d5 SHA512 59b755812d5d4463d43a4716d69951c9ff053bc91cd8bea9a588d8a1fddd4a9747943de26c77d2e786c4fbd5cc8c8b4e7af4c0619c0d434ad3fe732939eec064
+EBUILD exo-4.19.0.ebuild 964 BLAKE2B cbf725ab449f27f6783cf9491362f13a54d60078f73aaeb8a842012ab4ba9a01b3507789b99019766ad38dcdc64b433aba8bc1c02284fa16392d8d7e031c1d1f SHA512 7b9d2b849b0eec79efbcb4fe79715d404053b6ef93807ca8edb126cf666b27625ee3f2940c2ac1c857082b81526d57684539210758f8c0e958a0d0065881d11f
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/xfce-base/exo/exo-4.19.0.ebuild b/xfce-base/exo/exo-4.19.0.ebuild
new file mode 100644
index 000000000000..1f0b2f08307d
--- /dev/null
+++ b/xfce-base/exo/exo-4.19.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/exo/start
+ https://gitlab.xfce.org/xfce/exo/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}