summaryrefslogtreecommitdiff
path: root/x11-wm/wm2/wm2-4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-wm/wm2/wm2-4-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-wm/wm2/wm2-4-r1.ebuild')
-rw-r--r--x11-wm/wm2/wm2-4-r1.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/x11-wm/wm2/wm2-4-r1.ebuild b/x11-wm/wm2/wm2-4-r1.ebuild
index dff832f2a2ec..423d2be09b8c 100644
--- a/x11-wm/wm2/wm2-4-r1.ebuild
+++ b/x11-wm/wm2/wm2-4-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Small, unconfigurable window manager"
HOMEPAGE="http://www.all-day-breakfast.com/wm2/"
@@ -11,22 +12,26 @@ SRC_URI="http://www.all-day-breakfast.com/wm2/${P}.tar.gz"
SLOT="0"
LICENSE="wm2 HPND"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="x11-libs/libXmu"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-gentoo.patch"
+ default
+
sed -e "s/CFLAGS/CXXFLAGS/" \
-e "s/\$(CCC) -o/\$(CCC) \$(LDFLAGS) -o/" \
-i Makefile || die #334681
sed 's/^#//' Config.h > wm2.conf
- if [ -e "/etc/wm2.conf" ]; then
- echo "#undef _CONFIG_H_" >> Config.h
- awk '/^[^/]/{print "#" $0}' /etc/wm2.conf >> Config.h
+ if [[ -e "${EPREFIX}"/etc/wm2.conf ]] ; then
+ echo "#undef _CONFIG_H_" >> Config.h || die
+ awk '/^[^/]/{print "#" $0}' "${EPREFIX}"/etc/wm2.conf >> Config.h || die
fi
}
@@ -39,18 +44,17 @@ src_compile() {
src_install() {
dobin wm2
+
insinto /etc
doins wm2.conf
dodoc README
}
pkg_postinst() {
- echo
elog "wm2 is unconfigurable after you have installed. If you want to"
elog "change settings of wm2, please have a look at /etc/wm2.conf"
elog "and rewrite it, then emerge wm2 again (wm2 ebuild uses settings"
elog "from that file automatically). If you think wm2 lacks some important"
elog "features that you want to use (such as background pixmaps),"
elog "consider using wmx, written by the same author."
- echo
}