summaryrefslogtreecommitdiff
path: root/x11-wm/windowlab/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/windowlab/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/windowlab/files')
-rw-r--r--x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch11
-rw-r--r--x11-wm/windowlab/files/windowlab-1.40-gentoo.diff53
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch b/x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch
new file mode 100644
index 000000000000..ed85936bbcd9
--- /dev/null
+++ b/x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch
@@ -0,0 +1,11 @@
+--- a/windowlab.h 2006-09-01 23:47:36.000000000 +0200
++++ b/windowlab.h 2006-09-01 23:47:49.000000000 +0200
+@@ -49,7 +49,7 @@
+ #ifdef XFT
+ #define DEF_FONT "-bitstream-bitstream vera sans-medium-r-*-*-*-100-*-*-*-*-*-*"
+ #else
+-#define DEF_FONT "-b&h-lucida-medium-r-*-*-10-*-*-*-*-*-*-*"
++#define DEF_FONT "fixed"
+ #endif
+
+ // use named colours, #rgb, #rrggbb or #rrrgggbbb format
diff --git a/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff b/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff
new file mode 100644
index 000000000000..b0a9b490eb0c
--- /dev/null
+++ b/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff
@@ -0,0 +1,53 @@
+--- a/Makefile 2009-11-05 21:04:45.000000000 +0000
++++ b/Makefile 2010-05-30 15:31:04.047559352 +0000
+@@ -5,18 +5,18 @@
+ EXTRA_LIBS += -lXext
+
+ # Set this to the hardcoded location of all files if it's not /
+-PREFIX = /usr/local
++PREFIX = /usr
+
+ # Set this to the directory, below PREFIX, where man pages
+ # are expected. Below this directory, the target "install"
+ # will put "windowlab.1x" in section "man1".
+-MANBASE = /man
++MANBASE = /share/man
+
+ # Set this to the location of the X installation you want to compile against
+-XROOT = /usr/X11R6
++XROOT = /usr
+
+ # Some flexibility for configuration location
+-CONFPREFIX = $(PREFIX)
++CONFPREFIX =
+ CONFDIR = /etc/X11/windowlab
+
+ # Set this to the location of the global configuration files
+@@ -43,7 +43,6 @@
+
+ # --------------------------------------------------------------------
+
+-CC = gcc
+ ifndef CFLAGS
+ CFLAGS = -g -O2 -Wall -W
+ endif
+@@ -63,15 +62,15 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- mkdir -p $(BINDIR) && install -m 755 -s $(PROG) $(BINDIR)
+- mkdir -p $(MANDIR) && install -m 644 $(MANPAGE) $(MANDIR) && gzip -9vfn $(MANDIR)/$(MANPAGE)
+- mkdir -p $(CFGDIR) && cp -i windowlab.menurc $(CFGDIR)/windowlab.menurc && chmod 644 $(CFGDIR)/windowlab.menurc
++ install -D -m 755 $(PROG) $(BINDIR)/$(PROG)
++ install -D -m 644 $(MANPAGE) $(MANDIR)/windowlab.1
++ install -D -m 644 windowlab.menurc $(CFGDIR)/windowlab.menurc
+
+ clean:
+ rm -f $(PROG) $(OBJS)