summaryrefslogtreecommitdiff
path: root/x11-wm/stumpwm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
commit6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (patch)
tree401ffbc2ade49ce18f6182969ec5fb697a57ce48 /x11-wm/stumpwm
parentd4bd6695641f6d2ec7ff8681913d304e995902f5 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'x11-wm/stumpwm')
-rw-r--r--x11-wm/stumpwm/Manifest2
-rw-r--r--x11-wm/stumpwm/stumpwm-18.05.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/x11-wm/stumpwm/Manifest b/x11-wm/stumpwm/Manifest
index 34c6bb43c48c..3bc4e550d4c9 100644
--- a/x11-wm/stumpwm/Manifest
+++ b/x11-wm/stumpwm/Manifest
@@ -1,5 +1,7 @@
AUX 70stumpwm-gentoo.el 84 BLAKE2B 12ce0e9a1b53a1c1c84a9f350484b9620a2db9a30eaefb11bb409b89aae7f1226173930c52d018ec8a845c8e6ff69efd5570a369444537d070d21427a6960c09 SHA512 2e67f51dd6840f850aa1c0e3f2e8c2453203603f174f3ce97feacd2658cf6168bf557eb6ee83499b8c60fb107fdd527caccdda7ab5692646a33f96ad1350bcd1
AUX README.Gentoo 1894 BLAKE2B 23dd829621f92b2e5ab22bd3d54d9338d1034bd55d4adcfde24f6c0a780e41dddd747ee2baecdfd9b03a54de7e4acf08d903205dcdc68851afea5317401681aa SHA512 c187fcc12bbb4c10718e708a4b17a9adc89f1268270f231e8b5feeea881149482d8b70ac0f5eb78b7e0b93700d6cd5133bf7d844f97736bee793405de9a25a09
DIST stumpwm-1.0.1_rc.tar.gz 197530 BLAKE2B 2883ee8a0f75d3c673f6b6f65675c98e9fad8ef181b3ed9cf8bbd5eed7c0d63f3f48d021d056265d4e6c14dd0594bfe3a36492cd9bcdf2b3379d2aa62eba1f67 SHA512 3ba68987e61bdb46fde9c6bbed82b630be1db3272bdfb844a9d7abf3f810e94e560a28d4951308cab5af1f93b35710b10bb1a1a35450a8445a1b959888266df2
+DIST stumpwm-18.05.tar.gz 199467 BLAKE2B d532a531b7ceec7a80be66563dc2f36a6f1957d1e0f014ccf61cac1edf23073370dbe7cf3d7004f6dab144a88a4b54360e82ce7b13bdbc40cba59adfcb8e8af1 SHA512 a28c0af3a82670c0f31a5839227301672cc0706c47fb353355f90f791944556fb6125f3fa4d8547e6fbcf4817cdac5b0fe47de2dbae3a304d631a895af6ddb35
EBUILD stumpwm-1.0.1_rc.ebuild 1720 BLAKE2B a6289438611ad9fbc80574180ecc3c1e8a7f69e043e092c9bf65011bd8f302dcbb22eb3eefce1cec3a3ae4a62370456bde525df4f3463ef56db5bd77bd3c0fb9 SHA512 3a384f1a61caa62bd8ed598ef546d43a842beaf19cce966c319d6b8ae371f23ac1d0da5ff57a34078b112d051695a69ce512ae401ec64eadc4ac100513676b1d
+EBUILD stumpwm-18.05.ebuild 1636 BLAKE2B 9ad4bfb55786e66731069b3c54d6a5c62dd66d6bb3c54f597ac21b5f807a00847c93837242fcdb13437a0e21c95f156d96c407659b9e89cc3643f3bff156e0aa SHA512 ed4381c2b597db24ea622ff2b0de301be55a70a7917e4cbeb144b8a881e32b9f656b8c01987734a4fa698799ff5b61f19356e3d5d14e1c0f3dce30409e13a87f
MISC metadata.xml 2359 BLAKE2B 386ce110aa8b0cd933edaa6fa1dcd7f26d5ff8245317a77af546af6cbe89c9671bdf1c4810654fa0157c8220a04f0cd88e3dad482aab5402032a55d842ff93f2 SHA512 77068f2b6f1aa4b812c6b5251b9b4a0d0dabd08c1c868310c5c9a100ff7d159bb890516395bd7cbda9f6cd014f682d3c0cb2a03afa28e12ce4b2c5575c9c1eda
diff --git a/x11-wm/stumpwm/stumpwm-18.05.ebuild b/x11-wm/stumpwm/stumpwm-18.05.ebuild
new file mode 100644
index 000000000000..1da69a1a8997
--- /dev/null
+++ b/x11-wm/stumpwm/stumpwm-18.05.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 autotools elisp-common xdg-utils versionator
+
+DESCRIPTION="Stumpwm is a Window Manager written entirely in Common Lisp."
+HOMEPAGE="https://stumpwm.github.io/"
+SRC_URI="https://github.com/stumpwm/stumpwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib doc emacs"
+
+RESTRICT="strip mirror"
+
+RDEPEND="dev-lisp/alexandria
+ dev-lisp/cl-ppcre
+ dev-lisp/clx
+ >=dev-lisp/sbcl-1.3.0
+ emacs? ( virtual/emacs app-emacs/slime )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ doc? ( virtual/texi2dvi )"
+
+PDEPEND="contrib? ( x11-wm/stumpwm-contrib )"
+
+SITEFILE=70${PN}-gentoo.el
+CLPKGDIR="${CLSOURCEROOT}/${CLPACKAGE}"
+
+install_docs() {
+ local pdffile="${PN}.pdf"
+
+ texi2pdf -o "${pdffile}" "${PN}.texi.in" && dodoc "${pdffile}" || die
+ cp "${FILESDIR}/README.Gentoo" . && sed -i "s:@VERSION@:${PV}:" README.Gentoo || die
+ dodoc AUTHORS NEWS README.md README.Gentoo
+ doinfo "${PN}.info"
+ docinto examples
+ dodoc sample-stumpwmrc.lisp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ xdg_environment_reset
+ econf --with-lisp=sbcl
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin stumpwm
+ make_session_desktop StumpWM /usr/bin/stumpwm
+
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ # Fix ASDF dir
+ sed -i -e "/(:directory/c\ (:directory \"${CLPKGDIR}\")" \
+ "${D}${CLPKGDIR}/load-stumpwm.lisp" || die
+ use doc && install_docs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}