summaryrefslogtreecommitdiff
path: root/x11-wm/muffin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-wm/muffin
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-wm/muffin')
-rw-r--r--x11-wm/muffin/Manifest2
-rw-r--r--x11-wm/muffin/muffin-3.8.2.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/x11-wm/muffin/Manifest b/x11-wm/muffin/Manifest
index 58b6e623d921..d266a3d15a11 100644
--- a/x11-wm/muffin/Manifest
+++ b/x11-wm/muffin/Manifest
@@ -1,3 +1,5 @@
DIST muffin-3.6.0.tar.gz 2720809 BLAKE2B 9d1b92907d545990b409c15f9e9e3bf7b3871cc545d02234296efcb15f0082fc630c3a06849789c5e5aed4af9253e6893cc29feb7590aaaaaf2eb38843591c8d SHA512 d077f1310d7600754c9b4f77fc2a82377aec43f9a1cc0b95e28118764741922a58f2348418bee309d8c7fd1484b97ddc898d0105fa1a3fcd855d2fcc68f3679e
+DIST muffin-3.8.2.tar.gz 2723114 BLAKE2B f8218ac1f71ecfa5b74ca7ae8cf76d76e1207e3ce65f715643d477d2fb6429390671f3b05132a64f23a1853297f71563a62c052555f8a26d084469814972a64d SHA512 62dbfb602dd1164779e365e5e6f782431a491a254dcec8faef8a50f27f50cf7b0f8ab958b6df3b75d6b15edcd90c23a2fd6cc18cb11a2a513e669169f09cba05
EBUILD muffin-3.6.0.ebuild 2015 BLAKE2B a1e42826b62c46bd57de0f2a849525f9cc9eaa162279188a893f3108d33ca9e5a028a8fc1c6c5b7391d444d266773880f5bb6ed0e680609f4c3a387e40e10a6a SHA512 86c08741e7787f220d94900a34f5fe9db2a8b09d9caadfef96b76ba5051f5eb20409d38f1a7a0111c8791664dcad07046ef88cbe53557b199e41b8cd90c43341
+EBUILD muffin-3.8.2.ebuild 2017 BLAKE2B 747a1089dabd01eabc88e1d3aac8c7c458b55873011773da9ad0c85a7d18523532be188c52c1bc162f32442794cd129e1a07c0ce8dca812bb0bffa728e8c2b56 SHA512 d19b4c928844be00ad61cc8a41fc0c76847a895b08ad6bbfe51da256c38757041ffdbc1915b8e3fcec381e9e737f84d2217eff44a68276713b38145ae3b811ac
MISC metadata.xml 333 BLAKE2B d29a873cc8702d8251ff425eca5ec16b4ea2a75f4e512c05513c3a6a61e38e0fde4450158503cdb2e71b324c86a7e66e03c1eecba8bff6a6be81244f040ceaad SHA512 42c7d8e82dd95e76e6b72973d53a0a27de2562108b5989092c34804140d336dcb20b331a4c70b1fcf6730ef5f377f366f480271597c63f7ce3e8f7aa8d359555
diff --git a/x11-wm/muffin/muffin-3.8.2.ebuild b/x11-wm/muffin/muffin-3.8.2.ebuild
new file mode 100644
index 000000000000..691da9e9652a
--- /dev/null
+++ b/x11-wm/muffin/muffin-3.8.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.14:=[X]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.9.12:3[X,introspection?]
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=gnome-extra/cinnamon-desktop-2.4:0=[introspection?]
+ >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+ >=media-libs/clutter-1.14.3:1.0=[X,introspection?]
+ >=media-libs/cogl-1.13.3:1.0=[introspection?]
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/libXcomposite-0.3
+ >=x11-libs/startup-notification-0.7:=
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/opengl
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ xinerama? ( x11-libs/libXinerama )
+"
+# needs gtk-doc, not just -am, for gtk-doc.make
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( app-text/docbook-xml-dtd:4.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ gnome2_src_configure \
+ --disable-static \
+ --enable-shape \
+ --enable-sm \
+ --enable-startup-notification \
+ --enable-xsync \
+ --enable-verbose-mode \
+ --with-libcanberra \
+ $(use_enable introspection) \
+ $(use_enable xinerama)
+}