summaryrefslogtreecommitdiff
path: root/x11-wm/i3/i3-4.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /x11-wm/i3/i3-4.14.1.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'x11-wm/i3/i3-4.14.1.ebuild')
-rw-r--r--x11-wm/i3/i3-4.14.1.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/x11-wm/i3/i3-4.14.1.ebuild b/x11-wm/i3/i3-4.14.1.ebuild
index 1d884372499b..df485534f2f4 100644
--- a/x11-wm/i3/i3-4.14.1.ebuild
+++ b/x11-wm/i3/i3-4.14.1.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
AEVER=0.17
-inherit autotools virtualx
+inherit autotools out-of-source virtualx
DESCRIPTION="An improved dynamic tiling window manager"
HOMEPAGE="https://i3wm.org/"
SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
@@ -53,10 +54,6 @@ RDEPEND="${CDEPEND}
# in type-punned pointers - which in turn causes test failures.
REQUIRED_USE="test? ( debug )"
-DOCS=(
- "RELEASE-NOTES-${PV}"
- docs
-)
PATCHES=(
"${FILESDIR}/${PN}-musl-GLOB_TILDE.patch"
)
@@ -64,18 +61,6 @@ PATCHES=(
# https://github.com/i3/i3/issues/3013
RESTRICT="test"
-src_test() {
- emake -C "${CBUILD}" \
- test.commands_parser \
- test.config_parser \
- test.inject_randr15
-
- virtx perl \
- -I "${S}/testcases/lib" \
- -I "${CBUILD}/testcases/lib" \
- "${CBUILD}/testcases/complete-run.pl"
-}
-
src_prepare() {
default
@@ -87,22 +72,30 @@ src_prepare() {
eautoreconf
}
-src_configure() {
+my_src_configure() {
local myeconfargs=(
$(use_enable debug)
)
econf "${myeconfargs[@]}"
}
-src_compile() {
- emake -C "${CBUILD}"
+my_src_test() {
+ emake \
+ test.commands_parser \
+ test.config_parser \
+ test.inject_randr15
+
+ virtx perl \
+ -I "${S}/testcases/lib" \
+ -I "${BUILD_DIR}/testcases/lib" \
+ testcases/complete-run.pl
}
-src_install() {
- emake -C "${CBUILD}" DESTDIR="${D}" install
- doman "${S}"/man/*.1
+my_src_install_all() {
+ doman man/*.1
- use doc && einstalldocs
+ einstalldocs
+ use doc && dodoc -r docs "RELEASE-NOTES-${PV}"
exeinto /etc/X11/Sessions
doexe "${T}/i3wm"