summaryrefslogtreecommitdiff
path: root/x11-wm/i3/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /x11-wm/i3/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'x11-wm/i3/files')
-rw-r--r--x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch22
-rw-r--r--x11-wm/i3/files/i3-musl-GLOB_TILDE.patch86
2 files changed, 22 insertions, 86 deletions
diff --git a/x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch b/x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch
new file mode 100644
index 000000000000..6917aa091dff
--- /dev/null
+++ b/x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch
@@ -0,0 +1,22 @@
+diff --git a/meson.build b/meson.build
+index 11541e21..a6f8974e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -642,7 +642,7 @@ if get_option('docs')
+ '@OUTPUT@',
+ ],
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', 'i3'),
++ install_dir: docdir,
+ )
+
+ custom_target(
+@@ -655,7 +655,7 @@ if get_option('docs')
+ '@OUTPUT@',
+ ],
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', 'i3'),
++ install_dir: docdir,
+ )
+ endif
+
diff --git a/x11-wm/i3/files/i3-musl-GLOB_TILDE.patch b/x11-wm/i3/files/i3-musl-GLOB_TILDE.patch
deleted file mode 100644
index d241a748186e..000000000000
--- a/x11-wm/i3/files/i3-musl-GLOB_TILDE.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From: Natanael Copa <ncopa@alpinelinux.org>
-Patch-Source: https://git.alpinelinux.org/cgit/aports/tree/community/i3wm/musl.patch
-Project-Bug-URL: https://github.com/i3/i3/issues/1859
-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=609306
-
-Musl doesn't implement GLOB_TILDE, which is used by i3 when expanding paths.
-
-This patch replaces usage of GLOB_TILDE in glob() by replacing tilde
-with the content of $HOME - if set - manually.
-
-As mentioned in the i3 bugtracker this is an issue that should be solved by musl.
-
-A patch has been sent to musl upstream, but it hasn't been merged yet:
-http://www.openwall.com/lists/musl/2017/01/17/1
----
---- i3-4.11/i3bar/src/main.c
-+++ i3-4.11/i3bar/src/main.c
-@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
- *
- */
- char *expand_path(char *path) {
-- static glob_t globbuf;
-- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
-- ELOG("glob() failed\n");
-- exit(EXIT_FAILURE);
-+ char *home, *expanded;
-+
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
-- globfree(&globbuf);
-- return result;
-+
-+ return sstrdup(path);
- }
-
- void print_usage(char *elf_name) {
---- i3-4.11/libi3/resolve_tilde.c
-+++ i3-4.11/libi3/resolve_tilde.c
-@@ -19,27 +19,18 @@
- *
- */
- char *resolve_tilde(const char *path) {
-- static glob_t globbuf;
-- char *head, *tail, *result;
-+ char *home, *expanded;
-
-- tail = strchr(path, '/');
-- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
--
-- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
-- free(head);
-- /* no match, or many wildcard matches are bad */
-- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
-- result = sstrdup(path);
-- else if (res != 0) {
-- err(EXIT_FAILURE, "glob() failed");
-- } else {
-- head = globbuf.gl_pathv[0];
-- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strncpy(result, head, strlen(head));
-- if (tail)
-- strncat(result, tail, strlen(tail));
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- globfree(&globbuf);
-
-- return result;
-+ return sstrdup(path);
- }