summaryrefslogtreecommitdiff
path: root/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'x11-wm/herbstluftwm/herbstluftwm-9999.ebuild')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 0cea06f49ee7..c68ba3acf29a 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -7,11 +7,11 @@ inherit toolchain-funcs bash-completion-r1
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm.git"
- EXTRA_DEPEND="app-text/asciidoc"
+ BDEPEND="app-text/asciidoc"
else
SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- EXTRA_DEPEND=""
+ BDEPEND=""
fi
DESCRIPTION="A manual tiling window manager for X"
@@ -21,19 +21,23 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="examples xinerama zsh-completion"
-CDEPEND=">=dev-libs/glib-2.24:2
+DEPEND="
+ >=dev-libs/glib-2.24:2
x11-libs/libX11
x11-libs/libXext
- xinerama? ( x11-libs/libXinerama )"
-RDEPEND="${CDEPEND}
+ xinerama? ( x11-libs/libXinerama )
+"
+RDEPEND="
+ ${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
- ${EXTRA_DEPEND}
- virtual/pkgconfig"
+ zsh-completion? ( app-shells/zsh )
+"
+BDEPEND+="
+ virtual/pkgconfig
+"
src_compile() {
- tc-export CC LD CXX
+ tc-export CC CXX LD PKG_CONFIG
emake LDXX="$(tc-getCXX)" COLOR=0 VERBOSE= \
$(use xinerama || echo XINERAMAFLAGS= XINERAMALIBS= )