summaryrefslogtreecommitdiff
path: root/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'x11-wm/herbstluftwm/herbstluftwm-9999.ebuild')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild44
1 files changed, 17 insertions, 27 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 191f2848d3bf..c6dbf314e58c 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs bash-completion-r1
+inherit toolchain-funcs cmake-utils
-if [[ ${PV} == 9999* ]] ; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
BDEPEND="app-text/asciidoc"
@@ -36,37 +36,27 @@ BDEPEND+="
virtual/pkgconfig
"
-src_compile() {
- tc-export CC CXX LD PKG_CONFIG
+src_configure() {
+ sed -i \
+ -e '/^install.*LICENSEDIR/d' \
+ -e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
+ CMakeLists.txt || die
- emake LDXX="$(tc-getCXX)" COLOR=0 VERBOSE= \
- $(use xinerama || echo XINERAMAFLAGS= XINERAMALIBS= )
+ mycmakeargs=(
+ -DWITH_XINERAMA=$(usex xinerama)
+ )
+
+ cmake-utils_src_configure
}
src_install() {
- dobin herbstluftwm herbstclient
- dodoc BUGS MIGRATION NEWS README.md
-
- doman doc/{herbstluftwm,herbstclient}.1
-
- exeinto /etc/xdg/herbstluftwm
- doexe share/{autostart,panel.sh,restartpanels.sh}
-
- insinto /usr/share/xsessions
- doins share/herbstluftwm.desktop
-
- newbashcomp share/herbstclient-completion herbstclient
+ cmake-utils_src_install
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins share/_herbstclient
+ if ! use examples; then
+ rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
- if use examples ; then
- exeinto /usr/share/doc/${PF}/examples
- doexe scripts/*.sh
- docinto examples
- dodoc scripts/README
- docompress -x /usr/share/doc/${PF}/examples
+ if ! use zsh-completion; then
+ rm -r "${ED}"/usr/share/zsh || die
fi
}