summaryrefslogtreecommitdiff
path: root/x11-wm/fvwm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-05 08:07:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-05 08:07:19 +0100
commitc411f65f26582f4c75d2edbf4fa90a708474ace3 (patch)
treea530098a38ad69dcc0e9ec69f47a1bca219d8253 /x11-wm/fvwm
parenta5a60a0e01733705770f24a57953bf44ee06467d (diff)
gentoo auto-resync : 05:08:2022 - 08:07:19
Diffstat (limited to 'x11-wm/fvwm')
-rw-r--r--x11-wm/fvwm/Manifest1
-rw-r--r--x11-wm/fvwm/fvwm-2.6.9-r1.ebuild170
2 files changed, 171 insertions, 0 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 5892b16d35b7..24f3a2e0ea9e 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -4,5 +4,6 @@ AUX fvwm-2.6.5-ar.patch 1077 BLAKE2B ebd3226a706087c7e7f7935a9862c59e628551e19be
AUX fvwm-2.6.5-mouse-buttons.patch 519 BLAKE2B 23b31933e9dcc456d73be15573226017fc213da59156040136ff447b208b45691fca00b5d16cdaf57ab8411e2834d759b3bb7e53550b13ec72de4b7f70486abb SHA512 d28a9724697859ca7beac1cc2813c12413654e1c0749297c34fb0ef8bbf97369ac8039d2a82ec673d885b39e1544259b70cecf292639caa9ff99c1b42d34c196
AUX fvwm-2.6.8-perl528.patch 515 BLAKE2B 44df7b8aef71d85c3aefefb40ab45b9e6227ef6a13aaab60cec8956db669013b4ee4dc869216972e1a443d1f69e6550e7f80dc81cdf8b7642d6c49ae46793b2a SHA512 ab35b8aef3c6d8a07f1e03290c209736ee892729d98fece3d0134fd9994f8c57bdd5703492b405a6eb52cfcd67cd9cd72c16bc25a729a46560eb6e21f2d7918f
DIST fvwm-2.6.9.tar.gz 3942859 BLAKE2B 8faf2d420d96049ab0528a6c6a5dc6ed8ee9449f8e533b9ad9bb526faea86030684fc0aa8ed0d307cb64575457676611298adf582b1249c37a3db35a72b43bf1 SHA512 a9c2214ad19edd17da81446a6d4250284cc50b59b53c233212f2a9354c01143dbb870521392752f272f00af50bee2dd8f0b6bf6176b0d4b3075694d2a61a623e
+EBUILD fvwm-2.6.9-r1.ebuild 4328 BLAKE2B 779fa798311d4fbde9de3c64d314edc255427d8acc721e6ea42f824414d513e9afbf0fce6419fc259b0344e14c430b20edc93c385a6730df16181924609393d9 SHA512 98fe951afbe34acf243a6a09a4e76d27e69281ea1652cad4f33e943a46897156155de716b985dc689f83593d6303010387b5bf3ac2f959c297605b227ec34df5
EBUILD fvwm-2.6.9.ebuild 4078 BLAKE2B e11ab353d0dd3043dfe0dc9130ffe18f5c95449755eac396e982ef5ef33ddb5306e78139f9cc11adc49ee4e3ec8249cea71ba88f7cba64b8d680c12c944e3d47 SHA512 564b6a56cfce410003fcbdab0dc057c9ae8a7076578ec0ce376614c9af4a12ff3cb7d1b0ddfbde3299d022e3610e212b53a480abb793e671b1b9e6954b7d74c1
MISC metadata.xml 708 BLAKE2B 4f55c0b953de9742cad78d0ebba7c21b6cd5d71d373bcbe6e17233626b9447175eb87559284d4b5c083b3ff5d2191fbbb7ba3044d7efd6a81ca731debe6a1cbc SHA512 61900fcc084c99d66e7a094e9777b589b472620da31d166b8d0d795e5f104d9c80298764cd787589666e6afa9f996f687bcc39db92ef7568e4eec9aa0624d141
diff --git a/x11-wm/fvwm/fvwm-2.6.9-r1.ebuild b/x11-wm/fvwm/fvwm-2.6.9-r1.ebuild
new file mode 100644
index 000000000000..f62fad64c0be
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.6.9-r1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit autotools flag-o-matic python-single-r1 desktop
+
+DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+HOMEPAGE="https://www.fvwm.org/"
+SRC_URI="https://github.com/fvwmorg/fvwm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ FVWM"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bidi debug doc netpbm nls perl png readline rplay stroke svg tk truetype +vanilla xinerama lock"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/libiconv
+ $(python_gen_cond_dep '
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ bidi? ( dev-libs/fribidi )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng:0= )
+ readline? (
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ )
+ stroke? ( dev-libs/libstroke )
+ svg? ( gnome-base/librsvg )
+ truetype? (
+ media-libs/fontconfig
+ x11-libs/libXft
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ sys-apps/debianutils
+ perl? ( tk? (
+ dev-lang/tk
+ dev-perl/Tk
+ >=dev-perl/X11-Protocol-0.56
+ )
+ )
+ rplay? ( media-sound/rplay )
+ lock? ( x11-misc/xlockmore )
+ netpbm? ( media-libs/netpbm )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-lang/perl
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # Enables fast translucent menus; patch from fvwm-user mailing list.
+ eapply -p0 "${FILESDIR}/${PN}-2.5.27-translucent-menus.diff"
+
+ # Allow more mouse buttons, bug #411811
+ eapply -p0 "${FILESDIR}/${PN}-2.6.5-mouse-buttons.patch"
+ fi
+
+ eapply -p0 "${FILESDIR}/${PN}-2.6.5-ar.patch" #474528
+
+ # Fix for Perl 5.28
+ eapply -p0 "${FILESDIR}/${PN}-2.6.8-perl528.patch"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm
+ --enable-iconv
+ --enable-package-subdirs
+ --enable-mandoc
+ $(use_enable bidi)
+ $(use_enable debug debug-msgs)
+ $(use_enable debug command-log)
+ $(use_enable doc htmldoc)
+ $(use_enable nls)
+ $(use_enable perl perllib)
+ $(use_enable png)
+ $(use_with readline readline-library)
+ $(use_with rplay rplay-library)
+ $(use_with stroke stroke-library)
+ $(use_enable svg rsvg)
+ $(use_enable truetype xft)
+ $(use_enable xinerama)
+ )
+
+ # Non-upstream email where bugs should be sent; used in fvwm-bug.
+ export FVWM_BUGADDR="maintainer-needed@gentoo.org"
+
+ # Recommended by upstream, reference ????
+ append-flags -fno-strict-aliasing
+
+ # Signed chars are required.
+ use ppc && append-flags -fsigned-char
+
+ use readline && myeconfargs+=( --without-termcap-library )
+
+ export ac_cv_path_PYTHON="${PYTHON}"
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ make_session_desktop fvwm /usr/bin/fvwm
+
+ if ! use lock; then
+ find "${D}" -name '*fvwm-menu-xlock' -exec rm -f '{}' \; 2>/dev/null
+ fi
+
+ if use perl; then
+ if ! use tk; then
+ rm "${D}"/usr/share/fvwm/perllib/FVWM/Module/Tk.pm || die
+ rm "${D}"/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm || die
+ find "${D}"/usr/share/fvwm/perllib -depth -type d -exec rmdir '{}' \; 2>/dev/null
+ fi
+ else
+ # Completely wipe it if ! use perl
+ rm -r "${D}"/usr/bin/fvwm-perllib "${D}"/usr/share/man/man1/fvwm-perllib.1
+ fi
+
+ # Utility for testing FVWM behaviour by creating a simple window with
+ # configurable hints.
+ if use debug; then
+ dobin "${S}"/tests/hints/hints_test
+ newdoc "${S}"/tests/hints/README README.hints
+ fi
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/fvwm" > "${D}"/etc/X11/Sessions/${PN} || die
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ dodoc docs/{COMMANDS,DEVELOPERS.md}
+
+ # README file for translucent menus patch.
+ if ! use vanilla; then
+ dodoc "${FILESDIR}"/README.translucency
+ ewarn "You are using a patched build, so, please, don't"
+ ewarn "report bugs at the fvwm-workers list unless you are"
+ ewarn "also able to reproduce them with a vanilla build (USE=vanilla)."
+ fi
+}