summaryrefslogtreecommitdiff
path: root/x11-wm/fvwm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 03:21:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 03:21:28 +0100
commit681aad60df032a891dbbfc38f3ea4b404d6a8579 (patch)
treeda5eff2b4d9c8cca5f6df280543b43707f372f69 /x11-wm/fvwm
parent2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (diff)
gentoo auto-resync : 06:08:2023 - 03:21:27
Diffstat (limited to 'x11-wm/fvwm')
-rw-r--r--x11-wm/fvwm/Manifest1
-rw-r--r--x11-wm/fvwm/fvwm-2.7.0-r1.ebuild171
2 files changed, 172 insertions, 0 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 2c3f0a23eeec..b0767ab5b6e3 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -7,5 +7,6 @@ AUX fvwm-2.7.0-clang16.patch 1821 BLAKE2B b8acc1740eb820128625a1aab94c00faf9ba22
DIST fvwm-2.6.9.tar.gz 3942859 BLAKE2B 8faf2d420d96049ab0528a6c6a5dc6ed8ee9449f8e533b9ad9bb526faea86030684fc0aa8ed0d307cb64575457676611298adf582b1249c37a3db35a72b43bf1 SHA512 a9c2214ad19edd17da81446a6d4250284cc50b59b53c233212f2a9354c01143dbb870521392752f272f00af50bee2dd8f0b6bf6176b0d4b3075694d2a61a623e
DIST fvwm-2.7.0.tar.gz 3933529 BLAKE2B b4be7083c2946cb2a0c48673271d490a49aba5aec8407169bedc5a35f55fe8cd2724a9f6570c5e7ea110652c04956570c874256f96fa5d920a2a1ede152c0c25 SHA512 fc9076c3f07f36b0b2c7c4d2bdf7bb1a711000e39316e327173548bc99dc2b8a29b591e3644e1492f87603b576cd4a3f58ecbdd84a4384d294417b3c56c81808
EBUILD fvwm-2.6.9.ebuild 4034 BLAKE2B 603b739468c0c94f41348b62014245fd465da01622079f0bbaa68f4f3c736bce79b716ad8a3d7d6787bcbf3245340827e6308f7a5e0948afaffc0c2566676a5b SHA512 2e30f69354c6070e8b47992435a8368bc636d50498cb90f4413328703b79c9f69d5e633df9c6056c2ef7e019db1d9e020e14bf0d2e6f254c1a96c94912a440f5
+EBUILD fvwm-2.7.0-r1.ebuild 4210 BLAKE2B 1c80be6deebdb568b55314d993c09848e93ff326988b0d9048a3d0f944a456974ffb7fad328ddc1a01f720f2be70928eaccfd3befa5d29a209fbefab7b85d437 SHA512 c89eed41528cb14d43635141f4579a44439d9f38acc1cf5fe9889edf2f0381629208734ed886c9525b7597895a58593c650bf62bc2d536b08203cf184a619f81
EBUILD fvwm-2.7.0.ebuild 4256 BLAKE2B b88389581da14df1c3328b439068d619ce071d1a847d7259babe787e65a9e2851b310795aa1c93b6ecec766f515ad0792b33747358fb04979b82a2a2a60c87d1 SHA512 3f5956ae078e98839a50f09aa70a43e6f732a7fb7a3749032a43166fd57405f7f9363e12315d3c03ce81d3098495906f8f8ba1b72b2089a9e3201b4a02c8645a
MISC metadata.xml 736 BLAKE2B c9ff0661b5a87747a83a9d0f88f2a994e23e9e741e669fab4bd42351f74eb9dd8d55ae7d9a56d3a865eef344484a489f08359cc0e44874787fed0538f977c159 SHA512 5b06fe1d24d811fe7c408f38849c06360a5e59d98e5076214cdf041f95f5ed5ae4b625331337ce7c0d00db62fd4db6ca78f6cb2902409f340ba47d8204ab5692
diff --git a/x11-wm/fvwm/fvwm-2.7.0-r1.ebuild b/x11-wm/fvwm/fvwm-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..81814e9c4295
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.7.0-r1.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools flag-o-matic python-single-r1 desktop
+
+DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+HOMEPAGE="https://www.fvwm.org/"
+SRC_URI="https://github.com/fvwmorg/fvwm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ FVWM"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bidi debug doc netpbm nls perl png readline stroke svg tk truetype +vanilla xinerama lock"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/libiconv
+ $(python_gen_cond_dep '
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ bidi? ( dev-libs/fribidi )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng:0= )
+ readline? (
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ )
+ stroke? ( dev-libs/libstroke )
+ svg? ( gnome-base/librsvg )
+ truetype? (
+ media-libs/fontconfig
+ x11-libs/libXft
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ sys-apps/debianutils
+ perl? ( tk? (
+ dev-lang/tk
+ dev-perl/Tk
+ >=dev-perl/X11-Protocol-0.56
+ )
+ )
+ lock? ( x11-misc/xlockmore )
+ netpbm? ( media-libs/netpbm )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-lang/perl
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # Enables fast translucent menus; patch from fvwm-user mailing list.
+ eapply -p0 "${FILESDIR}/${PN}-2.5.27-translucent-menus.diff"
+
+ # Allow more mouse buttons, bug #411811
+ eapply -p0 "${FILESDIR}/${PN}-2.6.5-mouse-buttons.patch"
+ fi
+
+ eapply -p0 "${FILESDIR}/${PN}-2.6.5-ar.patch" #474528
+
+ eapply "${FILESDIR}"/fvwm-2.7.0-clang16.patch
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm
+ --enable-iconv
+ --enable-package-subdirs
+ --enable-mandoc
+ --without-rplay-library
+ $(use_enable bidi)
+ $(use_enable debug debug-msgs)
+ $(use_enable debug command-log)
+ $(use_enable doc htmldoc)
+ $(use_enable nls)
+ $(use_enable perl perllib)
+ $(use_enable png)
+ $(use_with readline readline-library)
+ $(use_with stroke stroke-library)
+ $(use_enable svg rsvg)
+ $(use_enable truetype xft)
+ $(use_enable xinerama)
+ )
+
+ # Non-upstream email where bugs should be sent; used in fvwm-bug.
+ export FVWM_BUGADDR="maintainer-needed@gentoo.org"
+
+ # Recommended by upstream, reference ????
+ append-flags -fno-strict-aliasing
+
+ # Signed chars are required.
+ use ppc && append-flags -fsigned-char
+
+ use readline && myeconfargs+=( --without-termcap-library )
+
+ export ac_cv_path_PYTHON="${PYTHON}"
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ make_session_desktop fvwm /usr/bin/fvwm
+
+ if ! use lock; then
+ find "${D}" -name '*fvwm-menu-xlock' -exec rm -f '{}' \; 2>/dev/null
+ fi
+
+ if use perl; then
+ if ! use tk; then
+ rm "${D}"/usr/share/fvwm/perllib/FVWM/Module/Tk.pm || die
+ rm "${D}"/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm || die
+ find "${D}"/usr/share/fvwm/perllib -depth -type d -exec rmdir '{}' \; 2>/dev/null
+ fi
+ else
+ # Completely wipe it if ! use perl
+ rm -r "${D}"/usr/bin/fvwm-perllib "${D}"/usr/share/man/man1/fvwm-perllib.1
+ fi
+
+ # Utility for testing FVWM behaviour by creating a simple window with
+ # configurable hints.
+ if use debug; then
+ dobin "${S}"/tests/hints/hints_test
+ newdoc "${S}"/tests/hints/README README.hints
+ fi
+
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ ${PN}
+ EOF
+
+ dodoc docs/{COMMANDS,DEVELOPERS.md}
+
+ # README file for translucent menus patch.
+ if ! use vanilla; then
+ dodoc "${FILESDIR}"/README.translucency
+ ewarn "You are using a patched build, so, please, don't"
+ ewarn "report bugs at the fvwm-workers list unless you are"
+ ewarn "also able to reproduce them with a vanilla build (USE=vanilla)."
+ fi
+}