summaryrefslogtreecommitdiff
path: root/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild')
-rw-r--r--x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild54
1 files changed, 25 insertions, 29 deletions
diff --git a/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild b/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
index ec5b26ddccd2..c36ed4f3624f 100644
--- a/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
+++ b/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
@@ -1,26 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils flag-o-matic toolchain-funcs prefix xdg xdg-utils
+EAPI=7
-IUSE="nls xinerama bidi +truetype +imlib +slit +systray +toolbar vim-syntax"
-
-REQUIRED_USE="systray? ( toolbar )"
+inherit flag-o-matic toolchain-funcs prefix xdg
DESCRIPTION="X11 window manager featuring tabs and an iconbar"
-
-SRC_URI="mirror://sourceforge/fluxbox/${P}.tar.xz"
HOMEPAGE="http://www.fluxbox.org"
-SLOT="0"
+SRC_URI="mirror://sourceforge/fluxbox/${P}.tar.xz"
+
LICENSE="MIT"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="nls xinerama bidi +truetype +imlib +slit +systray +toolbar vim-syntax"
+
+REQUIRED_USE="systray? ( toolbar )"
-RDEPEND="
- !!<=x11-misc/fbdesk-1.2.1
- !!<=x11-misc/fluxconf-0.9.9
- !!<x11-themes/fluxbox-styles-fluxmod-20040809-r1
- bidi? ( >=dev-libs/fribidi-0.19.2 )
+RDEPEND="bidi? ( >=dev-libs/fribidi-0.19.2 )
imlib? ( >=media-libs/imlib2-1.2.0[X] )
truetype? ( media-libs/freetype )
vim-syntax? ( app-vim/fluxbox-syntax )
@@ -30,27 +26,27 @@ RDEPEND="
x11-libs/libXrandr
x11-libs/libXrender
xinerama? ( x11-libs/libXinerama )
- || ( x11-misc/gxmessage x11-apps/xmessage )
-"
-DEPEND="
- ${RDEPEND}
- bidi? ( virtual/pkgconfig )
- nls? ( sys-devel/gettext )
- x11-base/xorg-proto
-"
+ || ( x11-misc/gxmessage x11-apps/xmessage )"
+
+BDEPEND="bidi? ( virtual/pkgconfig )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
src_prepare() {
+ default
# We need to be able to include directories rather than just plain
# files in menu [include] items. This patch will allow us to do clever
# things with style ebuilds.
- epatch "${FILESDIR}"/gentoo_style_location-1.1.x.patch
+ eapply "${FILESDIR}"/gentoo_style_location-1.1.x.patch
eprefixify util/fluxbox-generate_menu.in
- epatch "${FILESDIR}"/osx-has-otool.patch
+ eapply "${FILESDIR}"/osx-has-otool.patch
# Fix bug #551522; 1.3.8 will render this obsolete
- epatch "${FILESDIR}"/fix-hidden-toolbar.patch
+ eapply "${FILESDIR}"/fix-hidden-toolbar.patch
# Add in the Gentoo -r number to fluxbox -version output.
if [[ "${PR}" == "r0" ]] ; then
@@ -65,9 +61,11 @@ src_prepare() {
src_configure() {
xdg_environment_reset
+
use bidi && append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)"
- econf $(use_enable bidi fribidi ) \
+ econf \
+ $(use_enable bidi fribidi ) \
$(use_enable imlib imlib2) \
$(use_enable nls) \
$(use_enable slit ) \
@@ -82,7 +80,6 @@ src_configure() {
src_compile() {
default
- ebegin "Creating a menu file (may take a while)"
mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"
# Call fluxbox-generate_menu through bash since it lacks +x
# chmod 744 may be an equal fix
@@ -90,7 +87,6 @@ src_compile() {
CHECKINIT="no. go away." HOME="${T}/home" \
bash "${S}/util/fluxbox-generate_menu" -is -ds \
|| die "menu generation failed"
- eend $?
}
src_install() {