summaryrefslogtreecommitdiff
path: root/x11-wm/ctwm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /x11-wm/ctwm
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'x11-wm/ctwm')
-rw-r--r--x11-wm/ctwm/Manifest2
-rw-r--r--x11-wm/ctwm/ctwm-4.0.1-r1.ebuild50
-rw-r--r--x11-wm/ctwm/files/ctwm-4.0.1-m4.patch21
3 files changed, 73 insertions, 0 deletions
diff --git a/x11-wm/ctwm/Manifest b/x11-wm/ctwm/Manifest
index 0f4df0fef235..dcaf95b630b4 100644
--- a/x11-wm/ctwm/Manifest
+++ b/x11-wm/ctwm/Manifest
@@ -1,3 +1,5 @@
+AUX ctwm-4.0.1-m4.patch 600 BLAKE2B 119ca96ba88e694d5a8269c67869e3185d15701dd9c3af921243db12793c4e90b2832aab9eba1ac432619472f1b2103474866853ccfe89aefda0679bbb6bab35 SHA512 d90b490d5a39dd1caf8c59b6753a65e0aa2e38a911ceef9e5b84d0c4b246b44072499d1853c7137e28f858d1856d33fd510b57b0ebef75097f98ebb6455fac77
DIST ctwm-4.0.1.tar.xz 656776 BLAKE2B 37d6011d04f8d64552a86608a4d3867e6e1b0135f45457886daee6be1ae23ca1e3079caa1a63befd1d17bcc640e40ba0f1ed92e0a0caf2c6182f6e282f012bf7 SHA512 8c5c0bf868ba36cf5acca1ac5dbcea9327f63892698ace5086fabe563632acbb578cefea44ac3de91dc15afdbdce0370169e14156525507b90dc8aca8d305bc6
+EBUILD ctwm-4.0.1-r1.ebuild 987 BLAKE2B 32ae1ffd4342c03dceb80a2b4105e78ff17623c40ab2fd987722fed11aad0bbeec3adfaf13cfa706814ec2db255a444168ade5fb5af9f8eaf9309640689e665a SHA512 2577410789ef7497f8f0a51f051a3350d08a16c0d4771f9922383909fa0d0a81dcb007fc126c0408c3328a4f82418a80bd58d2940ea720c9bcc7c279d42ec102
EBUILD ctwm-4.0.1.ebuild 881 BLAKE2B d476155cb7a13721f3c7c31932a3172d3753bf9c6bb87d8c9e7399bbbf87fc517c2a2b9e4fa24b92352cb6cd5a879cc26e83de604edb16e5e505dc135b5b4700 SHA512 819b7e3d0fff0ae88b1d6f6a4e86fde3c0ddaf51919fa28dd49ca95966fcaf72c7a0d04b5b926a66e18dcdf69761f2ec3d26f1e724b9f322ba588472687a0400
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/x11-wm/ctwm/ctwm-4.0.1-r1.ebuild b/x11-wm/ctwm/ctwm-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..7046fe0373d1
--- /dev/null
+++ b/x11-wm/ctwm/ctwm-4.0.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A clean, light window manager"
+HOMEPAGE="http://ctwm.org/"
+SRC_URI="${HOMEPAGE}dist/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ app-text/rman
+ virtual/jpeg
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ # http://bazaar.launchpad.net/~ctwm/ctwm/trunk/revision/597
+ "${FILESDIR}"/${P}-m4.patch
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # implicit 'isspace'
+ sed -i parse.c -e "/<stdio.h>/ a#include <ctype.h>" || die
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+ mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
+}
diff --git a/x11-wm/ctwm/files/ctwm-4.0.1-m4.patch b/x11-wm/ctwm/files/ctwm-4.0.1-m4.patch
new file mode 100644
index 000000000000..94aa5a02d822
--- /dev/null
+++ b/x11-wm/ctwm/files/ctwm-4.0.1-m4.patch
@@ -0,0 +1,21 @@
+=== modified file 'parse_m4.c'
+--- ctwm-4.0.1____orig/parse_m4.c 2016-05-03 20:19:31 +0000
++++ ctwm-4.0.1____MaFu/parse_m4.c 2017-06-13 10:37:46 +0000
+@@ -140,12 +140,15 @@
+ char client[MAXHOSTNAME], server[MAXHOSTNAME], *colon;
+ struct hostent *hostname;
+ char *vc, *color;
+- static char tmp_name[] = "/tmp/ctwmrcXXXXXX";
++#define TMPLFILE "/tmp/ctwmrcXXXXXX"
++ static char tmp_name[sizeof(TMPLFILE)];
+ int fd;
+ FILE *tmpf;
+ char *user;
+
+ /* Create temp file */
++ strcpy(tmp_name, TMPLFILE);
++#undef TMPLFILE
+ fd = mkstemp(tmp_name);
+ if(fd < 0) {
+ perror("mkstemp failed in m4_defs");
+