summaryrefslogtreecommitdiff
path: root/x11-wm/aewm/aewm-1.3.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /x11-wm/aewm/aewm-1.3.12-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'x11-wm/aewm/aewm-1.3.12-r1.ebuild')
-rw-r--r--x11-wm/aewm/aewm-1.3.12-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-wm/aewm/aewm-1.3.12-r1.ebuild b/x11-wm/aewm/aewm-1.3.12-r1.ebuild
new file mode 100644
index 000000000000..e0a143a90091
--- /dev/null
+++ b/x11-wm/aewm/aewm-1.3.12-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalistic X11 window manager"
+HOMEPAGE="https://www.red-bean.com/decklin/aewm/"
+SRC_URI="${HOMEPAGE}${P}.tar.bz2"
+
+LICENSE="MIT 9wm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-r1-gentoo.patch
+)
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ MANDIR="${ED}"/usr/share/man/man1 \
+ XROOT="/usr" \
+ install
+
+ dodoc NEWS README
+}