summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
commitf5ef7f2371babf22c2c3fad17108692b09e4c98e (patch)
tree7f195ab30a74fa23e6dd24307d67d0890714d093 /x11-wm
parent3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (diff)
gentoo auto-resync : 02:05:2024 - 00:00:17HEADmaster
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Manifest.gzbin9139 -> 9139 bytes
-rw-r--r--x11-wm/qtile/Manifest2
-rw-r--r--x11-wm/qtile/qtile-0.25.0.ebuild112
3 files changed, 114 insertions, 0 deletions
diff --git a/x11-wm/Manifest.gz b/x11-wm/Manifest.gz
index 9dccf682af9f..f660b86b83cf 100644
--- a/x11-wm/Manifest.gz
+++ b/x11-wm/Manifest.gz
Binary files differ
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 98f7541ec516..b60179e17f47 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1,5 +1,7 @@
AUX qtile-0.23.0-keyring.patch 1974 BLAKE2B 9184942042daf256fa746ccd2f1ce820538c6a8a136e2ebdfc2604d68fd62fb15fb491a225ee4952a9d83a696e2fa740ccbd4cbb3f8d5d4a7cc69daa42c57c34 SHA512 5df4557c316993c8aa16a82f570bb4dbf375389663f9cff928dc4d3e73ccf581487be0b428d10d98cbeef28e94737b6d305b7f5f28cbc3481ef39e68e10cb482
AUX qtile-session-r1 1860 BLAKE2B fb9345d3acc5e0fc5694065f12e2759e02aebc765925cb0ffcb1a776ec82e959503d8a8039238e4e48a5045a3118f2e37201a88d5255fd0a0782d2f8291d8a77 SHA512 41b37ba034b5dd7f3126142d2cfc5cf8986b521fc419d47e420582fc8b516df87249bd8e14c12d77691b93205ec3cd1249bfa040ef0691e0751c669f742570ee
DIST qtile-0.23.0.tar.gz 524536 BLAKE2B 9cf5b0cdffd7bc95ab7649827c221b20718f9dcc19b8ae2a50ceac5df3d71b117eef493a40523d81e60c8bc54b2103bc2a93775fcb20c025ec1dd84f9d809a19 SHA512 d6886df8efefacf90b1a5ec487c9a5a90414593900159213a218d638ef4f018b69284fe2cea707da12655a9736aad3df74a338a60344536e4d7eebcc9fc1090b
+DIST qtile-0.25.0.tar.gz 569312 BLAKE2B 3841ca41755f37191c659c039da45279393b5bbe94b3d532651548ba51d6dc62f3ac94cc5f3b02aa2b6c806e6bf97c9651756579b77938d133bdb1a697150626 SHA512 afd3267c70681d3656569f8ea88d02f35ab5d6baaa28b3d90f1b7552b5ed32c7d2f1f4f17272458ff2c39d0ca8f4fdb87748c9d7b4eb41031f3079126096c7d0
EBUILD qtile-0.23.0-r1.ebuild 2528 BLAKE2B f9ce358fc66266d64df063c0ec40cb1041355a21174a79b3276c9a12fee46cf9f49220cbb0aad288fac824c2d3f6c89e374b85847534de093169e3c277fd02bd SHA512 8a37e0dafd9c02da3994dde2dd148ba27851af8c2494801cdd68d3f1a3f283f5b47407d9ca5a0f8feb60d13bf8fd7bcd5133d8261c85342d068cd6108f1ff41d
+EBUILD qtile-0.25.0.ebuild 2519 BLAKE2B 41b5a877fcdb39dc2990d5dd444e4e751c6316db038450f7f312d42f4c9f106fb2c80adf634856336e33630ad0974913caad095a4eebbfce3f8d0cd7ae9d6b40 SHA512 e4648a579f66c63c94f52ef7c50965e03e51dd7531c72ce1525556222174254e98c34bfa17aa84c53603cb399e0a522540f4fc6414464a62a3b63956919f71b1
MISC metadata.xml 422 BLAKE2B 10ddda5d4485b4a3c76ff658a41e2b4ea6004413ea3d2d9d4b088a7a25de36e167ae70505c195467c2401df0396a40e2301cc29a25e7e4097ed20cc6335e8956 SHA512 5f5aeecab841345abe98b87180644e60f8e52a12fc2c354cdd3678d8ad5c8c1ba13790a1bc6fa5662587714f3af9566f6adbdbc355b18d632d0ffa3eb4e83106
diff --git a/x11-wm/qtile/qtile-0.25.0.ebuild b/x11-wm/qtile/qtile-0.25.0.ebuild
new file mode 100644
index 000000000000..3fe2733dd15e
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.25.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="
+ https://qtile.org/
+ https://github.com/qtile/qtile/
+ https://pypi.org/project/qtile/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pulseaudio wayland"
+
+RDEPEND="
+ >=dev-python/cairocffi-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-1.4.0[${PYTHON_USEDEP}]
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango
+ pulseaudio? (
+ dev-python/pulsectl-asyncio[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+ )
+ wayland? (
+ >=dev-python/pywlroots-0.16[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/libcst[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[X]
+ x11-base/xorg-server[xephyr,xvfb]
+ )
+ wayland? (
+ >=dev-python/pywlroots-0.16[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/can_import(\"wlroots.ffi_build\")/$(usex wayland True False)/" \
+ -i setup.py || die
+
+ # some tests expect bin/qtile
+ mkdir bin || die
+ cat >> bin/qtile <<-EOF || die
+ #!/bin/sh
+ exec qtile "\${@}"
+ EOF
+ chmod +x bin/qtile || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ local -x CFFI_TMPDIR=${T}
+ distutils-r1_src_compile
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # mypy stuff
+ test/test_check.py
+ test/migrate/test_check_migrations.py
+ # TODO: this test clearly requires x11 — so why is wayland
+ # variant being run?
+ 'test/backend/x11/test_window.py::test_urgent_hook_fire[wayland-2]'
+ )
+
+ # force usage of built module
+ rm -rf libqtile || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ nonfatal epytest --backend=x11 $(usev wayland '--backend=wayland') ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ insinto /usr/share/wayland-sessions
+ doins resources/qtile-wayland.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
+}