summaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 05:40:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 05:40:24 +0000
commit8786557f50665cfd3a22ad42ec92209c4d6eae66 (patch)
tree7cf41a52a48ef4334d8fd43daaff3c2212fa937f /x11-themes
parent4846d367ad566eb7f93a432cae0d261f28f65255 (diff)
gentoo auto-resync : 26:02:2024 - 05:40:24
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/Manifest.gzbin20570 -> 20567 bytes
-rw-r--r--x11-themes/fluent-icon-theme/Manifest2
-rw-r--r--x11-themes/fluent-icon-theme/fluent-icon-theme-2024.02.25.ebuild60
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-themes/Manifest.gz b/x11-themes/Manifest.gz
index 4cd4f315b095..5301377a68a7 100644
--- a/x11-themes/Manifest.gz
+++ b/x11-themes/Manifest.gz
Binary files differ
diff --git a/x11-themes/fluent-icon-theme/Manifest b/x11-themes/fluent-icon-theme/Manifest
index 70c97952e023..e518680edd99 100644
--- a/x11-themes/fluent-icon-theme/Manifest
+++ b/x11-themes/fluent-icon-theme/Manifest
@@ -1,3 +1,5 @@
DIST fluent-icon-theme-2023.06.07.tar.gz 6213271 BLAKE2B f088caa2c54f73923bef12f8fd30a286fd6ab0829ca3d6c40aabd2ddb71d0c70c6718a69a7c7b6039d7e5506c313fbe8ea14bbf9252e5524d06fe6fce73ec664 SHA512 7e85613a58ce1fad4c8b0b31b81bfe9b226982ab8ede2413d87e89a12d78aeffef01f0a20fcaccfda6431a88e7798dc00a0a824a73f938e7daa48cb799588738
+DIST fluent-icon-theme-2024.02.25.tar.gz 6397963 BLAKE2B 5f7d46c5dbabe3744fcb2d21869794d0883fe57d15ac88d928b35f2bd41ea201486a0cc7cdd9937d3f24bd2c169e9e4aa2afa4ebdc9bd7abcc7b9328472ab44e SHA512 5a671360bf0d2b4e904d710b7cf72fde6580c4c1496a3fbcadf90a826e38936714dae511f35be3f2fdea370f602bcff4d1260dd0d230e6bcba6426f406247cec
EBUILD fluent-icon-theme-2023.06.07.ebuild 1334 BLAKE2B 03e7a2a36dfbc7c2df8790beb1b52e931f0aac981f64a866b07d0128b0cf0c4fddfa0814eb7e8535e600e14b6d38858b7f4c4e071028cf90fe4e227777b099d9 SHA512 4fc77385ae36a04919b336f39ad98ae2c04f9aaeb5864d48e999253c336811916427a93c86d083b6cb641b0bc9e650e02436680bce7bc2c9ba3b3e861fd6fa72
+EBUILD fluent-icon-theme-2024.02.25.ebuild 1315 BLAKE2B f9780d30588b3569b9fb65c0b6ea63d0cb588884c265dc7df788cce861b0e5ab056906a522ce6edf9d9f3c6cbbac0e2c11191392a23b8b2b71cc37fc9f3ff530 SHA512 ad2ba994924d44637a40642eb3eb81675bd33fd36e43487d0e654566e6a66332c8f0283a7efd7637528dd8e2fa9a719353e66eedeeb9422ab4106fff4da81c95
MISC metadata.xml 761 BLAKE2B 6ff0f7e9cfd1ed82e6e34e8b730fa60ecfb4827467b5f0bc9aa94df860f54a28ad30290526046d28f952d794bbd287e000634fa24ea9a9aa9a4b088f076900c9 SHA512 54b5cb1d7da3a7098ec9e538c35c0e96349dcf828206d7ae7588444bd82e2a95b3a95306db1ec598b0684157133278386dacd48763d993669cc6269e0a5b4288
diff --git a/x11-themes/fluent-icon-theme/fluent-icon-theme-2024.02.25.ebuild b/x11-themes/fluent-icon-theme/fluent-icon-theme-2024.02.25.ebuild
new file mode 100644
index 000000000000..710dd4f9c2a9
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/fluent-icon-theme-2024.02.25.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ie. 2021.12.20 -> 2021-12-20
+MY_PV="${PV//./-}"
+MY_PN="${PN^}"
+
+inherit xdg
+
+DESCRIPTION="Fluent icon theme for Linux desktops"
+HOMEPAGE="https://github.com/vinceliuice/Fluent-icon-theme"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/${MY_PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+hardlink round"
+RESTRICT="binchecks strip test"
+
+BDEPEND="
+ sys-apps/util-linux[hardlink(-)?]
+"
+
+src_prepare() {
+ default
+
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ dodir /usr/share/icons
+ local -a myinstallopts=(
+ --all
+ --dest "${ED}/usr/share/icons"
+ $(usev round '--round')
+ )
+ bash ./install.sh "${myinstallopts[@]}" || die "install script failed"
+
+ if use hardlink ; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # Installs broken symlink. By design, but we remove it due to QA warnings.
+ find "${ED}" -xtype l -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}