summaryrefslogtreecommitdiff
path: root/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
commitb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (patch)
tree38e677f4a13244ca8ed29a815a0a62f943b430d4 /x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild
parentd37b97a25b8b10f748eead6574b01f893f140b01 (diff)
gentoo resync : 09.12.2017
Diffstat (limited to 'x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild')
-rw-r--r--x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild b/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild
new file mode 100644
index 000000000000..04a71f1d3957
--- /dev/null
+++ b/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Skins for SMPlayer"
+HOMEPAGE="https://www.smplayer.info/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ default
+
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+ sed -i -e "s|rcc -binary|$(qt5_get_bindir)/&|" themes/Makefile || die
+}
+
+src_install() {
+ rm themes/Makefile
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}