summaryrefslogtreecommitdiff
path: root/x11-themes/nuvox/nuvox-07.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/nuvox/nuvox-07.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/nuvox/nuvox-07.1-r1.ebuild')
-rw-r--r--x11-themes/nuvox/nuvox-07.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-themes/nuvox/nuvox-07.1-r1.ebuild b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
new file mode 100644
index 000000000000..328020ee4d52
--- /dev/null
+++ b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MY_P=nuvoX_${PV}
+
+DESCRIPTION="NuvoX SVG icon theme"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=38467"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/imagemagick-tools[png]"
+
+RESTRICT="strip binchecks"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/rm -fr/d' -e '/tar cf/d' buildset || die
+}
+
+src_compile() {
+ ./buildset || die
+}
+
+src_install() {
+ dodoc nuvoX_0.7/readme.txt
+ rm nuvoX_0.7/{readme,license}.txt
+
+ insinto /usr/share/icons/${PN}
+ doins -r nuvoX_0.7/*
+}