summaryrefslogtreecommitdiff
path: root/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild')
-rw-r--r--x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild b/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild
new file mode 100644
index 000000000000..d349b6633785
--- /dev/null
+++ b/x11-themes/mate-icon-theme-faenza/mate-icon-theme-faenza-1.20.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Faenza icon theme, that was adapted for MATE desktop"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="minimal"
+
+RDEPEND="x11-themes/hicolor-icon-theme:0
+ !minimal? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"
+
+RESTRICT="binchecks strip"
+
+# https://github.com/mate-desktop/mate-icon-theme-faenza/issues/13
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Remove broken libreoffice icons (dangling symlinks).
+ rm matefaenza/apps/16/*libreoffice* || die
+
+ mate_src_prepare
+}