summaryrefslogtreecommitdiff
path: root/x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild')
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild b/x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild
new file mode 100644
index 000000000000..81d8b32afb49
--- /dev/null
+++ b/x11-themes/lxqt-themes/lxqt-themes-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt Themes"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.10.0"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}