summaryrefslogtreecommitdiff
path: root/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild')
-rw-r--r--x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild b/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild
new file mode 100644
index 000000000000..cc4b1edc854b
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-extras/gnome-icon-theme-extras-3.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Extra GNOME icons for specific devices and file types"
+HOMEPAGE="https://git.gnome.org/browse/gnome-icon-theme-extras/"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+# FIXME: double check potential LINGUAS problem
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Always use pre-rendered icons
+ # FIXME: changing configure.ac triggers maintainer-mode rebuild
+ sed -e 's/"x$allow_rendering" = "xyes"/"x$allow_rendering" = "xdonotwant"/' \
+ -i configure || die
+}
+
+src_configure() {
+ gnome2_src_configure --enable-icon-mapping
+}