summaryrefslogtreecommitdiff
path: root/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild')
-rw-r--r--x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild b/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild
new file mode 100644
index 000000000000..78c5094149c1
--- /dev/null
+++ b/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="Some gnome-colors iconsets including a Gentoo one"
+HOMEPAGE="https://code.google.com/p/gnome-colors/"
+
+SRC_URI="https://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
+ https://dev.gentoo.org/~pacho/gnome-gentoo-${PV}.tar.gz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-themes/gnome-colors-common"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ dodir /usr/share/icons
+ insinto /usr/share/icons
+ for i in gnome*; do
+ if [ "$i" != "gnome-colors-common" ]; then
+ doins -r "${i}" || die
+ fi
+ done
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}