summaryrefslogtreecommitdiff
path: root/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild')
-rw-r--r--x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild b/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
new file mode 100644
index 000000000000..b759269da521
--- /dev/null
+++ b/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit gnome2-utils
+
+DESCRIPTION="Gargantuan Icon Theme"
+HOMEPAGE="http://www.gnome-look.org/content/show.php?content=24364"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/gargantuan"
+
+src_install() {
+ dodoc README
+ rm -f index.theme~ index.theme.old icons/iconrc~ README || die
+ insinto /usr/share/icons/gargantuan
+ doins -r *
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }