summaryrefslogtreecommitdiff
path: root/x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild')
-rw-r--r--x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild b/x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild
new file mode 100644
index 000000000000..e1a90202570c
--- /dev/null
+++ b/x11-themes/fluxbox-styles-fluxmod/fluxbox-styles-fluxmod-20050128-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+DESCRIPTION="A collection of FluxBox themes from FluxMod"
+HOMEPAGE="http://tenr.de/styles/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ # comment out every rootcommand
+ find . -name '*.cfg' -exec \
+ sed -i "{}" -e 's-^\(rootcommand\)-!!! \1-i' \;
+ # weird tarball...
+ find . -exec chmod a+r '{}' \;
+}
+
+src_install() {
+ insinto /usr/share/fluxbox/fluxmod/styles
+ doins -r * || die
+ insinto /usr/share/fluxbox/menu.d/styles
+ doins "${FILESDIR}"/styles-menu-fluxmod || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "These styles are installed into /usr/share/fluxbox/fluxmod/. The"
+ einfo "best way to use these styles is to ensure that you are running"
+ einfo "fluxbox 0.9.10-r3 or later, and then to place the following in"
+ einfo "your menu file:"
+ einfo
+ einfo " [submenu] (Styles) {Select a Style}"
+ einfo " [include] (/usr/share/fluxbox/menu.d/styles/)"
+ einfo " [end]"
+ einfo
+ einfo "If you use fluxbox-generate_menu or the default global fluxbox"
+ einfo "menu file, this will already be present."
+ einfo
+ einfo "Note that some of these styles use the PNG image format. For"
+ einfo "these to work, fluxbox must be built with USE=\"imlib\" and"
+ einfo "imlib2 must be built with USE=\"png\"."
+ einfo
+}