summaryrefslogtreecommitdiff
path: root/x11-themes/e-flat-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-themes/e-flat-theme
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-themes/e-flat-theme')
-rw-r--r--x11-themes/e-flat-theme/Manifest2
-rw-r--r--x11-themes/e-flat-theme/e-flat-theme-0_pre20200824.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/e-flat-theme/Manifest b/x11-themes/e-flat-theme/Manifest
index 126c8f1827c0..69dff1031029 100644
--- a/x11-themes/e-flat-theme/Manifest
+++ b/x11-themes/e-flat-theme/Manifest
@@ -1,3 +1,5 @@
DIST e-flat-theme-0_pre20200602.edj 45765496 BLAKE2B 008560100983b3e00782d9cfa7e0b8fe329085245b98ff335b5a29520e2379cacfc5e3958c9d474605631dc7e79f114f4a6a2eb8d0729216ef657cbc06732e84 SHA512 84bc4b9e84de581090409836d7c057aac7d0af971733767cdf8f8d8584d7c8f4e35ddfc775616df757d9cced8f8ad408a07d7f0c6222207b4579e850cd5c505e
+DIST e-flat-theme-0_pre20200824.edj 45979784 BLAKE2B 8b9d2ddba3c6cb213ded3768625ca900ed10292c918918afa9b29f2de83696fa83dc8c93865a9b5cb916875371d573012df4d5e734dc579b28f9e9cbceb475e0 SHA512 90774cd48e0f3de9fe1609836272de692339bd935ec1379a943f2bfa04f56a9b2cd091f5860eb570606ad517e3f01b6ae41c99caeb86b5f2755114e608736c15
EBUILD e-flat-theme-0_pre20200602.ebuild 1030 BLAKE2B 2ca159a5e899f025df21fbf47ddc0baaf95405b3499f626e19d2207b12af6ee3d2583c54662ffd1e1d51f655e05c1adcc9193c5ce16e8cf0c5d5a2b9ccaaa6e4 SHA512 f1da95b5eafbc2933cbdf47c5705f353693a37019d2479cb51739983016aa699e79918ca5ef887415cac7aab5587ff67fd1e08eea68a5ac5928177d207c53ae5
+EBUILD e-flat-theme-0_pre20200824.ebuild 1030 BLAKE2B 2ca159a5e899f025df21fbf47ddc0baaf95405b3499f626e19d2207b12af6ee3d2583c54662ffd1e1d51f655e05c1adcc9193c5ce16e8cf0c5d5a2b9ccaaa6e4 SHA512 f1da95b5eafbc2933cbdf47c5705f353693a37019d2479cb51739983016aa699e79918ca5ef887415cac7aab5587ff67fd1e08eea68a5ac5928177d207c53ae5
MISC metadata.xml 254 BLAKE2B 938f68b7b21ad386a35540a09e4bb956e241dfc963d4823c3c0cd46d3449ff4fb5a1cead67ad7c35a460503d30bdbde35822535f1c2d46f2939ee190f328b846 SHA512 26047ebb40fc49bfb4393121c5c5af69caee617a1d75676be84b0f5af75564828aeeef4503c7681eaaf7e48f6c662574874336296c18e002dca8e925162a1d4c
diff --git a/x11-themes/e-flat-theme/e-flat-theme-0_pre20200824.ebuild b/x11-themes/e-flat-theme/e-flat-theme-0_pre20200824.ebuild
new file mode 100644
index 000000000000..1ce5c3e1babc
--- /dev/null
+++ b/x11-themes/e-flat-theme/e-flat-theme-0_pre20200824.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern, flat theme for Enlightenment WM"
+HOMEPAGE="https://www.enlightenment.org/ https://phab.enlightenment.org/T6726"
+SRC_URI="https://dev.gentoo.org/~juippis/distfiles/${P}.edj"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+RDEPEND="x11-wm/enlightenment"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # doins doesn't allow installing straight from DISTDIR.
+ cp "${DISTDIR}"/${P}.edj . || die "Failed to prepare theme file."
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/elementary/themes/
+ newins ${P}.edj flat-0.edj
+}
+
+pkg_postinst() {
+ elog "You'll find e-flat-theme under System themes in theme selector."
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn ""
+ ewarn "You're updating flat-0 theme. Please reload Enlightenment"
+ ewarn "through Menu -> Enlightenment -> Restart, or by issuing"
+ ewarn " enlightenment -restart"
+ ewarn ""
+ fi
+}