summaryrefslogtreecommitdiff
path: root/x11-themes/adwaita-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /x11-themes/adwaita-qt
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'x11-themes/adwaita-qt')
-rw-r--r--x11-themes/adwaita-qt/Manifest2
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/Manifest b/x11-themes/adwaita-qt/Manifest
index d1cf0b8e7a4e..857b28779921 100644
--- a/x11-themes/adwaita-qt/Manifest
+++ b/x11-themes/adwaita-qt/Manifest
@@ -1,3 +1,5 @@
DIST adwaita-qt-1.0.tar.gz 565625 BLAKE2B 73dba06dd785131d8bb949b5dcb195994d415e295b196228fd6145687431a3fd4984489c81322cfd1437fa8de3a97e41b30b49bba35baa30b379e02770b52928 SHA512 35993a9f99f9d41812d448d679a9e7a8cb15e8ed9b23a2ea9a33c61c1bfc98a226f8bea2fce3ff0dab29420ff10c4e4a4a800c9b989475cc66c4042257fe154c
+DIST adwaita-qt-1.1.0.tar.gz 435576 BLAKE2B e85e918e2527cc26f7804f1b03e75163b8c30d46402e3de3dca7afb93ac7abd81fe5e10b4d858859cf9abf443ec57cf74cc1ab578a45798dcb73d4b17da08cc5 SHA512 5203b64cb9e4038579c68ae8f52bc8c2fcdaf0ab46ce134f2a92b318493cc69718ce4d69968f1da20fcdf5f5492c38a6a225475f74f75390ada1337d35504a01
EBUILD adwaita-qt-1.0-r1.ebuild 869 BLAKE2B 2bc8dac1f9c4b2616c1289ecd62f3d347c1a5b6d87474bfbf07deebf560c84ce44b4fb073eb1db87589aa4f12a097f5b7936a04f1adfe6654bdb4e64b16776ce SHA512 490da64221a05af780f1aa9a85adf2e5a3a30c1f555bb804feff3921013b82bfc63525c9f3b97348b9074114fd3d484ac8d418a19e20e076f7d8998df67b1788
+EBUILD adwaita-qt-1.1.0.ebuild 865 BLAKE2B ad9b366a608dbfa9f6910d0cdc683229d7f975d85e2d4fe71ba872768251d708986235d951eb9cd24e13477b4223917cde56991722bf98dd8307ac069a1bff41 SHA512 f84dae99dbe4a906d90dee8d11832e04845797fc35130d882f75d0731376606586104a4f2da21b067cb5b74884010718c0fce45d6fdf6bd2542b14dd0c71ec7d
MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
new file mode 100644
index 000000000000..5e4cc7643b77
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="gnome"
+
+RDEPEND="
+ gnome? ( x11-themes/QGnomePlatform )
+ dev-qt/qtwidgets:5
+ dev-qt/qtdbus:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BUILD_DIR="${WORKDIR}/${PN}_qt5"
+ local mycmakeargs=( -DUSE_QT4=OFF )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_compile -C "${_d}"
+ done
+}
+
+src_install() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_install -C "${_d}"
+ done
+}