summaryrefslogtreecommitdiff
path: root/x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
commitb0378783c1929d283116fe183089c123dba5869c (patch)
treeefe69bfa7e38c36238f6e5a9341f6194b949e6f5 /x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild
parente374e165c2ee372e9c6d10860ea6ef47f180f6b2 (diff)
gentoo auto-resync : 02:10:2022 - 13:12:50
Diffstat (limited to 'x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild')
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild
new file mode 100644
index 000000000000..cba1b3bb0681
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="gnome"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${DEPEND}"
+PDEPEND="gnome? ( x11-themes/QGnomePlatform )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ )
+ cmake_src_configure
+}