summaryrefslogtreecommitdiff
path: root/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild')
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
new file mode 100644
index 000000000000..bfb8d37af0b5
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="gnome"
+
+RDEPEND="
+ gnome? ( x11-themes/QGnomePlatform )
+ dev-qt/qtwidgets:5
+ dev-qt/qtdbus:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ BUILD_DIR="${WORKDIR}/${PN}_qt5"
+ local mycmakeargs=( -DUSE_QT4=OFF )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_compile -C "${_d}"
+ done
+}
+
+src_install() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_install -C "${_d}"
+ done
+}