summaryrefslogtreecommitdiff
path: root/x11-themes/QGnomePlatform
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /x11-themes/QGnomePlatform
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'x11-themes/QGnomePlatform')
-rw-r--r--x11-themes/QGnomePlatform/Manifest2
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/Manifest b/x11-themes/QGnomePlatform/Manifest
index ce043dc80d44..4e37f5d2e760 100644
--- a/x11-themes/QGnomePlatform/Manifest
+++ b/x11-themes/QGnomePlatform/Manifest
@@ -1,3 +1,5 @@
DIST QGnomePlatform-0.6.0.tar.gz 28618 BLAKE2B af4ef5c54a8056a370a8d6299fd80bace2491a97c9bff99ce5a461a1c3ab07c6a5336fa88606805e37102ccc648217722331ec9e572ce3708581b713ee399d0d SHA512 c5aad4518e1c9d06b2561a6f8a6a169bf9a07ec0a63602d3bc5b0f91e1134504f5ca0e5a76bda3183165c72bf8de3e9297b51fe37879d80c1fbe4ca06e242a97
+DIST QGnomePlatform-0.6.1.tar.gz 28996 BLAKE2B 3d0da37fcc8e85bd59263dffb19865666d25dd50d2c1e00b4d6358d745eb7079f415058ffb75a8228c9c7ed956003a656b3e10a3467d9fc9dcd5eee2c14bf7cd SHA512 5e0bab45a8ff4c56e6e34d636ed719ce1a087f116942dd356253403d4be40aac348ccbdbfc917f65f6cc4df8619e1031734f0a46a36d4d9b7bb4838ded61570c
EBUILD QGnomePlatform-0.6.0-r1.ebuild 634 BLAKE2B 8ae5634bbc6f11dd6c98d0f31646fd8432f0b47c58e987532946bc97be6212a05bce73cfd2cd79ec49c118fbc50939215a816bfd3d3ffb0c2b41a9d0dcb1e4ca SHA512 65d85f2c24164f9db965d1331533a4aa775158aa11bd20919c7201f2d9a6719cedf5cdc54c079577b9de42c3d3b6b075f0ae7fd0e75bd60c88b44422324d04a5
+EBUILD QGnomePlatform-0.6.1.ebuild 636 BLAKE2B b1d9e23be320efbdf4b190f2ca1844001880e4a675001828dd9beeb0b55128929702904aa5e0336bdac5c329db4942e94c6cae9895408d3f2ba2fc0d5a008b86 SHA512 12137f3202220d4d87889c2df1615fa5aa6512fa87f18db1b62d3ba94ab4ebcbd14b20db8b96a8bc320a25311bdc510aa265b78adfbaede0dc27ce9c9a7e5198
MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild
new file mode 100644
index 000000000000..65c5840ce9d0
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtwidgets-5.6:5=
+ dev-qt/qtwayland:5=
+ dev-qt/qtx11extras:5=
+ x11-libs/gtk+:3[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}