summaryrefslogtreecommitdiff
path: root/x11-terms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-05 23:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-05 23:43:10 +0000
commitd82c6c919aa63b46ec1683492b75162951f09072 (patch)
tree559264efa71b0a426b715aee43022d8f5c714b06 /x11-terms
parentc31f575f39c1e387f18f630fb01d3a89c2339fdf (diff)
gentoo auto-resync : 05:02:2024 - 23:43:10
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/Manifest.gzbin4556 -> 4558 bytes
-rw-r--r--x11-terms/xfce4-terminal/Manifest2
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-1.1.2.ebuild59
3 files changed, 61 insertions, 0 deletions
diff --git a/x11-terms/Manifest.gz b/x11-terms/Manifest.gz
index e6c3a3d45143..b0fbf9f24a1e 100644
--- a/x11-terms/Manifest.gz
+++ b/x11-terms/Manifest.gz
Binary files differ
diff --git a/x11-terms/xfce4-terminal/Manifest b/x11-terms/xfce4-terminal/Manifest
index b55deaa2ea78..e6e3d451537d 100644
--- a/x11-terms/xfce4-terminal/Manifest
+++ b/x11-terms/xfce4-terminal/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-terminal-1.1.1.tar.bz2 1033180 BLAKE2B e33bf7f0ff56200154a7195b6aaf09a7b67c7577c78190fd110b1dc035914295735925bf82f0cd3b6809646315236a32fc835acbb8d97b73b57025205faef9e8 SHA512 0f2631cc9790b467495cf17a506c33b9c6a037b94a353cb870554b1dd9da0b4795ed965ca2e9beb5dec1b344304e4dc9f71130862f6b45d63f66c603757991cd
+DIST xfce4-terminal-1.1.2.tar.bz2 1042199 BLAKE2B 5919899a7e76e31a05f13485a38564a38dba37335b412a7d548d107ea8ed5eea9edb087ac75e9a90364b5e9a0aaa4b8b32342ac3a8e026da0c3cf73bd8903c81 SHA512 ffd0975dc839e256ee18c8a5cb01025bfc2703af7d379d565ea861482269698c718c4cca408440cdc76ef7c6ccacaa6816da7f6734b1aef004cfb223f657243a
EBUILD xfce4-terminal-1.1.1.ebuild 1277 BLAKE2B af239b8535d3dbc9af6ae9062a773b0186a54d8e67e4864d334146251a0a6578fa0555d2c5b01c3ee0e39b25f445ee0d1b0a891b7ed3144d3d6ad476e2857789 SHA512 0de4a6146b8732f4991fc3fbf0d79a13fea1afc05c436e10dbcf611bee0ed6c5ba5af1f9946f988caae5ab7233877dae828f8e98c6bae4a472c684adaf906f9e
+EBUILD xfce4-terminal-1.1.2.ebuild 1283 BLAKE2B 937d95d01e5973782557b5c914d7494d7f5d423954673016dd850981e50cfb51785232ee0309a9be17387e5c1b58579c7c852093201101b88708128643618ace SHA512 7b364a62057a879e27ccba6866a0ef512fd76d9f09ac60b95df012a21388d43ad4443e12e4ae523ad9b30b64ddc05c02a3bfd255c1d16969dea89da358cbf160
MISC metadata.xml 372 BLAKE2B bb4bcd3652bb3bbaee272af26e6b07b5279167c165574cfcbaa1c23d8b9786cc79972325893fc563aac5ae1eef257ebe4807199497a02c147515af68b80e27a2 SHA512 722c99f01658541a9d1df513ffa218ac36897644e771d8b439bf6b2c38e241304c0a43c94115ed95f367ba6e3a8606bee2c63ef8c1ef9841f08b9f06977751c7
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-1.1.2.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.2.ebuild
new file mode 100644
index 000000000000..1937b280276f
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/terminal/start
+ https://gitlab.xfce.org/apps/xfce4-terminal/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libpcre2-10.00:=
+ >=x11-libs/gtk+-3.22.0:3[wayland?,X?]
+ >=x11-libs/vte-0.51.3:2.91
+ >=xfce-base/libxfce4ui-4.17.5:=[gtk3(+)]
+ >=xfce-base/xfconf-4.16.0:=
+ utempter? ( sys-libs/libutempter:= )
+ wayland? ( >=gui-libs/gtk-layer-shell-0.7.0 )
+ X? ( >=x11-libs/libX11-1.6.7 )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}